[POJ](3061)Subsequence ---- 尺取法

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

尺取法讲解: 尺取法(一)

这个题一年之前做过,没想到当时自己写出了尺取法,还不知道当时是神马情况,蒟蒻!变捞了!

注释: POJ还是加速外挂和万用头文件用不了呀!

AC代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;
const int maxn = 1e5+10;
int a[maxn];
int n,s;
int flag;
int inchworm()
{
    int i=0,j=0;
    int sum = a[0];
    int ans = 0x3f3f3f3f;
    while(i<=j && j<n)
    {
        if(sum>=s)
        {
            ans = min(ans,j-i+1);
            sum-=a[i];
            i++;
            flag = 1;
        }
        else
        {
            j++;
            sum+=a[j];
        }
    }
    return ans;
}
int main()
{
    #ifdef LOCAL
    freopen("in.txt","r",stdin);
    #endif //LOCAL
//    ios_base::sync_with_stdio(false);
//    cin.tie(NULL),cout.tie(NULL);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        flag = 0;
        scanf("%d %d",&n,&s);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        int ans = inchworm();
        if(flag) printf("%d\n",ans);
        else
            printf("0\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值