acm Subsequence 3061

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
 
 
点击打开链接
开始一直陷在用二分要先排序的套路里,忘了这是个序列= =
后来百度了很多,觉得自己的思路和尺取法差不多,然而还是不对
照着大佬的敲了一遍
总结一下套路
左右端点取0;

while(sum<s&&r<n)
  sum+=a[r++]; //先移动右端点
  if(sum<s)   
    break;
  ans=min(ans,r-l);//取最小长度
  sum-=a[l++];//移动左端点//因为在while循环里,所以会取到最小的长度直到满足sum<s,跳出循环
 
 
 
#include<cstdio>
#include<algorithm>
using namespace std;
int a[100005];
int main()
{
	int n,m,s;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d%d",&n,&s);
		int i;
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		int l=0,r=0,sum=0,ans=n+2;
		while(1)//不明白为什么要用while//果然= =就是为了找到sum<s的ans值
		{//永远执行直到跳出
			while(sum<s&&r<n)
			  sum+=a[r++];
			  if(sum<s)
			  break;//难到是为了跳出?
			  ans=min(ans,r-l);
			  sum-=a[l++];
		}printf("%d\n",ans==n+2?0:ans);
	}return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值