[LightOJ](1282)Leading and Trailing ---- double快速幂

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5
123456 1
123456 2
2 31
2 32
29 8751919

Sample Output

Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

题意: 给你n,k 让你求n^k的最左边的三位和最右边的三位

思路: 后三位快速幂取模,前三位用double模拟快速幂保精度

AC代码:

#include<bits/stdc++.h>
using namespace std;
#define rep(i,s,e)      for(int i=s;i<=e;i++)
#define rev(i,s,e)      for(int i=e;i>=s;i--)
#define all(x)          x.begin(),x.end()
#define sz(x)           x.size()
#define szz(x)          int(x.size()-1)
const int INF = 0x3f3f3f3f;
const int MOD =  1e9+7;
const int MAXN = 2e5+10;
typedef long long LL;
typedef pair<LL,LL> PII;
LL qpow(LL a,LL p)
{
    LL tmp = 1;
    while(p)
    {
        if(1&p) tmp = (tmp*a)%1000;
        a = (a*a)%1000;
        p>>=1;
    }
    return tmp;
}
int main()
{
    #ifdef LOCAL
    freopen("in.txt","r",stdin);
    #endif // LOCAL
//    ios_base::sync_with_stdio(0);
//    cin.tie(0),cout.tie(0);
    int t,id = 1;
    scanf("%d",&t);
    while(t--)
    {
        LL n,k;
        scanf("%I64d%I64d",&n,&k);
        int tmp1 = qpow(n,k);
        double a = n*1.0;
        double tmp2 = 1.0;
        while(k)//double类型模拟快速幂,保留精度
        {
            if(k&1)
            {
                tmp2 = a*tmp2;
                while(tmp2>=1000.0)
                    tmp2/=10.0;
            }
            a*=a;
            while(a>=1000.0)
                a/=10.0;
            k>>=1;
        }
        printf("Case %d: %03d %03d\n",id++,(int)tmp2,tmp1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值