[LightOJ](1245)Harmonic Number (II) ---- 调和级数(规律)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11
1
2
3
4
5
6
7
8
9
10
2147483647

Sample Output

Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386

题意: 给你一个n,让你求调和级数n
调和级数就是 n/1+n/2+n/3+……+n/n,注意这里的除是计算机的内的除

思路: 题中给的代码就是暴力1e9,再算上t个数据,即使时间限制3000ms,也肯定超时。

然后自己找了一个规律,或者说是分治的思想,找在哪一段中元素都是1,哪一段中元素都是2,哪一段中元素都是3……这样分成1e5个段,然后剩下的再去循环即可。酱紫时间复杂度就优化了。

AC代码: 用时808ms

#include<bits/stdc++.h>
#define rep(i,s,e)      for(int i=s;i<=e;i++)
#define rev(i,s,e)      for(int i=e;i>=s;i--)
using namespace std;
const int maxn = 1e5;
typedef long long LL;
int t[maxn];
LL H(int n)
{
    LL res = 0;
    rep(i,1,maxn)
        t[i] = n/(i+1);
    rep(i,1,t[maxn])
        res = res+n/i;
    res += n-t[1];
    rep(i,2,maxn)
        res = res+i*(t[i-1]-t[i]);
    return res;
}
int main()
{
    #ifdef LOCAL
    freopen("in.txt","r",stdin);
    #endif // LOCAL
    int t,n;
    int id = 1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case %d: %lld\n",id++,H(n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值