折半枚举(双向搜索) poj 4 Values whose Sum is 0

4 Values whose Sum is 0
Time Limit: 15000MS

Memory Limit: 228000K
Total Submissions: 24097

Accepted: 7307
Case Time Limit: 5000MS
Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5

题解:
///例子: 四个数组中的数加起来等于0
/// 将问题转化为 两个数组 减上 两个数组何为一个数组的和 病等于0的情况
/// 例子: c+d=-a-b 将c d数组加进一个为n*n的数组中 并且将其值排序 然后再比较没一个值是否相等统计相等的有几个
/// 因此我们采取排序 使用二分查找去确定有几个相等的值 然后叠加

如果暴力的话 时间复杂度在  o(n^4)
如果在两个数组中暴力 在o(n^2)

此算法的时间复杂度在 O(n^2 log n)

#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
using namespace std;
const int maxn=8000;
int n,res;
int a[maxn],b[maxn],c[maxn],d[maxn];
int cd[maxn*maxn];  //   c和d中的数组的组合  cd=c+d
///例子:    四个数组中的数加起来等于0
///  将问题转化为   两个数组 减上 两个数组何为一个数组的和 病等于0的情况
///   例子:   c+d=-a-b     将c d数组加进一个为n*n的数组中 并且将其值排序 然后再比较没一个值是否相等统计相等的有几个
///   因此我们采取排序 使用二分查找去确定有几个相等的值 然后叠加

void solve(){
    //将c和d数组中的值加进一个数组中
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)    cd[i*n+j]=c[i]+d[j];
    sort(cd,cd+n*n);
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++){
            int ab=-(a[i]+b[j]);
            res+=upper_bound(cd,cd+n*n,ab)-lower_bound(cd,cd+n*n,ab);
        }
        cout<<res<<endl;
}
int main(){
    cin>>n;
    for(int i=0;i<n;i++)    cin>>a[i]>>b[i]>>c[i]>>d[i];
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值