解决:当前 .NET SDK 不支持将 .NET Core 3.0 设置为目标

解决:当前 .NET SDK 不支持将 .NET Core 3.0 设置为目标

解决该bug的途径有两种:

1. 将 .NET Core 2.1 或更低版本设置为目标

2. 使用支持 .NET Core 3.0 的 .NET SDK 版本

 

由于开发平台是Microsoft .NET Core 3.0,因此只能选择第二种解决途径。

1. 首先,下载 .NET Core 3.0 Priview7 SDK:https://dotnet.microsoft.com/download/dotnet-core/3.0

(现在貌似已经推出Priview8了,可以根据个人情况选择下载版本)

下载完后,可以查看是否下载成功:

DOS命令输入:dotnet --info

如上显示,则表示安装成功。

2.安装SDK之后,VS2019默认不会开启对.NET Core 3.0 的支持,需要进行设置。

打开VS2019 --> 调试 --> 选项 ,如下图所示:

然后重启VS就能正常使用 .NET Core 3.0 了。

发布了46 篇原创文章 · 获赞 91 · 访问量 1万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览