HDU 6201transaction 【树形DP】


2017 ACM/ICPC Asia Regional Shenyang Online

HDU 6201

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are n1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer T ( 1T10 ) , the number of test cases.
For each test case:
first line contains an integer n ( 2n100000 ) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1Price10000)
then follows n1 lines, each contains three numbers x , y and z which means there exists a road between x and y , the distance is z km (1z1000) .
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8


题意:给一棵树,树点有权值(书价格),树边是消耗,从任意一个点买一本树,卖到另一个点,求最大利益。

思路:树形DP,用dp[x][0],表示在x的子树买一本的获得最大权值(为负的),dp[x][1]表示在x的子树卖一本书所获得的最大权值。答案就是在每一个节点的买卖书,注意可以不买也不卖获利为零。


ACcode

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long  LL;
const int N=100005;
LL dp[N][2],ans;
int val[N],n,m;
struct edge
{
    int to,cost;
    edge(){}
    edge(int x,int y)
    {
        to=x;
        cost=y;
    }
};
vector<edge>g[N];
void dfs(int x,int fa)
{
    dp[x][0]=-val[x];
    dp[x][1]=val[x];
    for(int i=0;i<g[x].size();i++)
    {
        int y=g[x][i].to;
        if(y==fa)continue;
        dfs(y,x);
        dp[x][0]=max(dp[x][0],dp[y][0]-g[x][i].cost);
        dp[x][1]=max(dp[x][1],dp[y][1]-g[x][i].cost);
    }
    ans=max(ans,dp[x][0]+dp[x][1]);
}
int main()
{
    int TA,x,y,z;
    scanf("%d",&TA);
    while(TA--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)g[i].clear();
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            g[x].push_back(edge(y,z));
            g[y].push_back(edge(x,z));
        }
        ans=0;
        dfs(1,-1);
        printf("%lld\n",ans);
    }
    return 0;
}








  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值