Strategic game

Strategic game

总时间限制: 

2000ms 

内存限制: 

65536kB

描述

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree:


the solution is one soldier ( at the node 1).

输入

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0)


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

输出

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

样例输入

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

样例输出

1
2

来源

Southeastern Europe 2000

 

求最小边覆盖,动规

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
using namespace std;
int dp[1505][2];
vector<int>V[1505];
int root;
int solve(int x)
{
	dp[x][0]=0;
	dp[x][1]=1;
	for(int i=0;i<V[x].size();++i)
	{
		int son=V[x][i];
		solve(son);
		dp[x][0]+=dp[son][1];
		dp[x][1]+=min(dp[son][0],dp[son][1]);
	}
	return min(dp[x][0],dp[x][1]);
}
int main()
{
	int n,a,b,x;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=0;i<=n;++i)
			V[i].clear();
	    root=-1;
		for(int i=0;i<n;++i)
		{
			scanf("%d:(%d)",&a,&b);
			if(root==-1)
			{
				root=a;
			}
			for(int j=0;j<b;++j)
			{
				scanf("%d",&x);
				V[a].push_back(x);
			}
		}
		printf("%d\n",solve(root));
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值