poj 2054:Color a Tree 贪心

2054:Color a Tree

总时间限制: 

1000ms 

内存限制: 

65536kB

描述

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes.

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try.

Each node has a "coloring cost factor", Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi.

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.


Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

输入

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed.

输出

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

样例输入

5 1
1 2 1 2 4
1 2
1 3
2 4
3 5
0 0

样例输出

33

来源

Beijing 2004

#include<iostream>//基本思想:除了根结点外,任何一个价值最大的节点的父节点被访问之后必须马上访问这个节点。
#include<cmath>//于是可以把这个点和父节点合并成一个节点,并修改权值,不断重复直到只剩一个节点。 
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
using namespace std;
struct Node
{
	int father;
	int c;
	double w;//记录权值,反映平均代价 
	int cnt;//记录当前这个节点是由几个节点合并成的 
}N[1005];
int n,r;
int main()
{
	while(cin>>n>>r)
	{
		if(n==0&&r==0)break;
		int sum=0;
		for(int i=1;i<=n;++i)
		{
			cin>>N[i].c;
			N[i].w=N[i].c;
			N[i].cnt=1;
			sum+=N[i].c;
		}
		for(int i=0;i<n-1;++i)
		{
			int s,t;
			cin>>s>>t;
			N[t].father=s;
		}
		for(int i=1;i<=n-1;++i)
		{
			int pos=0;//找权值最大的节点 
			double Max=-1;
			for(int j=1;j<=n;++j)
			{
				if(N[j].w>Max&&j!=r)
				{
					Max=N[j].w;
					pos=j;
				}
			}
			N[pos].w=0;
			int f=N[pos].father;
			sum+=N[pos].c*N[f].cnt;
			for(int j=1;j<=n;++j)//把权值最大的节点的子节点的父节点修改 
			{
				if(N[j].father==pos)
				{
					N[j].father=f;
				}
			}
			N[f].c+=N[pos].c;
			N[f].cnt+=N[pos].cnt;
			N[f].w=(double)N[f].c/N[f].cnt;//记录平均代价 
		}
		cout<<sum<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值