poj3088:Snowflake (Hash)

3088:Snowflake

总时间限制: 

30000ms 

单个测试点时间限制: 

1000ms 

内存限制: 

65536kB

描述

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

输入

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

输出

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

样例输入

2
1 2 3 4 5 6
4 3 2 1 6 5

样例输出

Twin snowflakes found.
将每个六元组hash起来实现O(1)查找
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
using namespace std;
const int Prime=99991;
int n;
int a[100005][6];
vector<int>Hash[Prime];
bool Identical(int x,int y)
{
	for(int i=0;i<6;++i)
	{
		if(a[x][i]==a[y][0]&&a[x][(i+1)%6]==a[y][1]
		&&a[x][(i+2)%6]==a[y][2]&&a[x][(i+3)%6]==a[y][3]
		&&a[x][(i+4)%6]==a[y][4]&&a[x][(i+5)%6]==a[y][5])
		{
			return true;
		} 
		if(a[x][i]==a[y][0]&&a[x][(i+5)%6]==a[y][1]
		&&a[x][(i+4)%6]==a[y][2]&&a[x][(i+3)%6]==a[y][3]
		&&a[x][(i+2)%6]==a[y][4]&&a[x][(i+1)%6]==a[y][5])
		{
			return true;
		} 
	} 
	return false;
}
int main()
{
	cin>>n;
	for(int i=0;i<n;++i)
	{
		for(int j=0;j<6;++j)
		{
			cin>>a[i][j];
		}
	}
	for(int i=0;i<n;++i)
	{
		int sum=0;
		for(int j=0;j<6;++j)
		{
			sum+=a[i][j];
		}
		sum=sum%Prime;
		for(int j=0;j<Hash[sum].size();++j)
		{
			if(Identical(i,Hash[sum][j]))
			{
				cout<<"Twin snowflakes found."<<endl;
				return 0;
			}
		}
		Hash[sum].push_back(i);
	}
	cout<<"No two snowflakes are alike."<<endl;
	return 0;
}



  •  
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值