POJ3349 Snowflake Snow Snowflakes(hash)

3 篇文章 0 订阅

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 35715 Accepted: 9399

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.



题目链接:点击打开链接


给出n个由6个数字组成的雪花, 问是否存在两个雪花是相同的.

观察数据, 暴力的话会TLE. 采用哈希表, 将所有雪花存入哈希表, 若读到两个雪花相等, 就提前结束.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int MAXN = 1e5 + 5;
int n, a[6];
bool flag;
struct node
{
	/* data */
	int num[6];
	node *nxt;
	node() {
		for(int i = 0; i < 6; ++i)
			num[i] = -1;
		nxt = NULL;
	}
}snow[MAXN];
int main(int argc, char const *argv[])
{
	scanf("%d", &n);
	while(n--) {
		int sum = 0;
		for(int i = 0; i < 6; ++i) {
			scanf("%d", &a[i]);
			sum += a[i];
		}
		if(!flag) {
			sort(a, a + 6);
			node *p = &snow[sum % 10000];
			while(p -> nxt != NULL && !flag) {
				p = p -> nxt;
				for(int i = 0; i < 6; ++i) 
					if(p -> num[i] != a[i]) break;
					else if(p -> num[i] == a[i] && i == 5) flag = true;
			}
			node *x = new node;
			for(int i = 0; i < 6; ++i)
				x -> num[i] = a[i];
			p -> nxt = x;
		}
	}	
	if(flag) printf("Twin snowflakes found.\n");
	else printf("No two snowflakes are alike.\n");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值