HDU-1024-Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34230    Accepted Submission(s): 12209


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
 
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
 
 
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 

题意

最大m段字段和问题

给n个数,将其分为m部分,各部分之间不能有交叉重叠,求最大和

题解

dp[i][j]表示前j个数分为i部分的最大和,则 
dp[i][j] = max(dp[i][j-1] + a[j], dp[i-1][k] + a[j]) i-1<=k<=j-1 

前者是将第j个数加入到第i部分,后者是将第j个数做为第i部分的第一个数。

Notice:

  1. 因为题目n值范围过大,显然二维数组不行。 
    而d[i][x]只与d[i-1][x]有关,所以可以将其降低至一维。 
    即dp[j]表示前j个数所分段后的和。
  2. 因为dp[i-1][k]的取值需要一重循环,极有可能导致超时,所以使用数组max存储当前层的最大值,以供下一层求值使用。 
    dp[j] = max(dp[j-1] + a[j], max[j-1] + a[j])

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
const int INF = 0x3f3f3f3f;
int dp[maxn],d[maxn];
int num[maxn],mmax;
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=1;i<=n;i++) scanf("%d",&num[i]);
        memset(dp,0,sizeof(dp));
        memset(d,0,sizeof(d));
        for(int i=1;i<=m;i++) {
            mmax = -INF;
            for(int j=i;j<=n;j++) {
                dp[j] = max(dp[j-1],d[j-1]) + num[j];//zd
                d[j-1] = mmax;
                mmax = max(mmax,dp[j]);
            }
        }
        printf("%d\n",mmax);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值