[二分-最小化最大值] - poj3273-Monthly Expense

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 32395 Accepted: 12180

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

给你一个长度为N的序列,现在要让你把他们切割成M份(所以每一份都是连续的),然后每一份都有一个和sum[i],其中最大的一个是maxSum = max(sum[i]),问这个最大值最小是多少?

题解:

二分枚举maxSum,计算对于当前的maxSum是否可以构成M份,如果小于<=M份,则maxSum还可以再小一点.

需要注意的是下界的选取,maxSum的最小值是序列中的最大值,maxSum至少大于max{num[i]}!!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
ll arr[maxn];
int n,m;
bool check(ll mid) {
    int cnt = 1;
    ll sum = 0;
    for(int i=0;i<n;i++) {
        if(sum + arr[i] <= mid) sum += arr[i];
        else sum = arr[i],cnt++;
    }
    return cnt <= m;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        ll left = -1,right = 0;
        for(int i=0;i<n;i++) scanf("%lld",&arr[i]),right += arr[i],left = max(left,arr[i]);
        /// 这里的下界要大于最大的,保证每一天可以单独为一个月.下界要小于其和
        while(left <= right) {
            ll mid = (left+right) / 2;
            if(check(mid)) right = mid - 1;
            else left = mid + 1;
        }
        printf("%lld\n",left);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值