POJ - 1821 Fence 单调队列优化DP

Fence

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5933 Accepted: 1900

Description

A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct. 

Being the team's leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income. 

Write a program that determines the total maximal income obtained by the K workers. 

Input

The input contains: 
Input 

N K 
L1 P1 S1 
L2 P2 S2 
... 
LK PK SK 

Semnification 

N -the number of the planks; K ? the number of the workers 
Li -the maximal number of planks that can be painted by worker i 
Pi -the sum received by worker i for a painted plank 
Si -the plank in front of which sits the worker i 

Output

The output contains a single integer, the total maximal income.

Sample Input

8 4
3 2 2
3 2 3
3 3 5
1 1 7 

Sample Output

17

Hint

Explanation of the sample: 

the worker 1 paints the interval [1, 2]; 

the worker 2 paints the interval [3, 4]; 

the worker 3 paints the interval [5, 7]; 

the worker 4 does not paint any plank 

Source

Romania OI 2002


题目

现在有n个地板需要画,同时有k个工人分别坐在S[i]位置上。

每个工人只能画他周围最多L[i]个位置,即如果画必须画上S[i]位置,每画一个可得到P[i]的金钱。

现在要求总的最大金钱。


题解

直观的想法

dp[i][j] 表示前i个工人画到第j个地板所得到的最大金钱。

那么dp[i][j] = max(dp[i][j-1],dp[i-1][j]) 

(假设当前第i个工人不画第j个位置,那么dp[i][j] 就等于前i个工人画到第j-1个或者前i-1个工人画到第j个的最大值)

如果画上第j个位置

则dp[i][j] = max(dp[i-1][k]+(j-k)*P[i],dp[i][j])

k是枚举的上一个工人画到什么位置 

j-L[i]<=k<S[i] 上一个工人不能画到S[i] 因为第i个工人必须要画上S[i]的位置

S[i]<=j<S[i]+L[i]

于是可以写出O(n^2k)的dp

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int maxn = 2e4+10;
ll dp[105][maxn]; // dp[i][j] : 表示前i个工人画到第j个木板所获得的最大金钱数.
int n,k;
struct Person{
    int L,P,S;
    bool operator < (const Person &a) const {
        return S < a.S;
    }
}worker[105];
int main()
{
    while(~scanf("%d%d",&n,&k)) {
        for(int i=1;i<=k;i++) scanf("%d%d%d",&worker[i].L,&worker[i].P,&worker[i].S);
        sort(worker+1,worker+k+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=k;i++) {
            for(int j=1;j<=n;j++) {
                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                if(j>=worker[i].S && j<worker[i].S+worker[i].L) {
                    for(int k=max(j-worker[i].L,0);k<worker[i].S;k++) {
                        dp[i][j] = max(dp[i-1][k]+(j-k)*worker[i].P,dp[i][j]);
                    }
                }
            }
        }
        printf("%lld\n",dp[k][n]);
    }
    return 0;
}

显然是超时的。

我们注意到

dp\left [ i \right ]\left [ j \right ] = max\left \{ dp\left [ i \right ]\left [ k \right ] +\left ( j-k \right ) \ast P\left [ i \right ]\right \}

\left ( S[i]\leq j <S[i]+L[i]\right ) (j-L[i]\leq k< S[i])

显然满足单调队列的性质。那么将公式转化成

dp\left [ i \right ]\left [ j \right ] = max\left \{ dp\left [ i \right ]\left [ k \right ] -k* P\left [ i \right ] + j * P[i]\right \}

单调队列维护一下dp\left [ i \right ]\left [ k \right ] -k* P\left [ i \right ] 的最大值,然后注意一下 k 的范围

需要注意的是需要添加一个0值点到单调队列,因为有前面所有工人都没用画的情况。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<deque>
using namespace std;
typedef long long ll;
const int maxn = 2e4+10;
ll dp[105][maxn]; // dp[i][j] : 表示前i个工人画到第j个木板所获得的最大金钱数.
int n,k;
deque<pair<int,ll> > qu;
struct Person{
    int L,P,S;
    bool operator < (const Person &a) const {
        return S < a.S;
    }
}worker[105];
int main()
{
    while(~scanf("%d%d",&n,&k)) {
        qu.clear();
        for(int i=1;i<=k;i++) scanf("%d%d%d",&worker[i].L,&worker[i].P,&worker[i].S);
        sort(worker+1,worker+k+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=k;i++) {
            qu.clear();
            qu.push_back(make_pair(0,0));
            for(int j=1;j<=n;j++) {
                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                if(j < worker[i].S) {
                    while(!qu.empty() && qu.back().second < dp[i-1][j] - j * worker[i].P) qu.pop_back();
                    qu.push_back(make_pair(j,dp[i-1][j]-j*worker[i].P));
                }
                else {
                    while(!qu.empty() && qu.front().first+worker[i].L < j) qu.pop_front();
                    if(!qu.empty()) {
                        dp[i][j] = max(qu.front().second + j*worker[i].P,dp[i][j]);
                    }
                }
            }
        }
        printf("%lld\n",dp[k][n]);
    }
    return 0;
}

如果使用了数组模拟双端队列时间优化了不少

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<deque>
using namespace std;
typedef long long ll;
const int maxn = 2e4+10;
ll dp[105][maxn]; // dp[i][j] : 表示前i个工人画到第j个木板所获得的最大金钱数.
int n,k;
pair<int,ll> qu[maxn];
struct Person{
    int L,P,S;
    bool operator < (const Person &a) const {
        return S < a.S;
    }
}worker[105];
int main()
{
    while(~scanf("%d%d",&n,&k)) {
        for(int i=1;i<=k;i++) scanf("%d%d%d",&worker[i].L,&worker[i].P,&worker[i].S);
        sort(worker+1,worker+k+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=k;i++) {
            int h = 1,t = 0;
            qu[++t] = make_pair(0,0);
            for(int j=1;j<=n;j++) {
                dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                if(j < worker[i].S) {
                    while(h<=t && qu[t].second < dp[i-1][j] - j * worker[i].P) t--;
                    qu[++t] = make_pair(j,dp[i-1][j]-j*worker[i].P);
                }
                else {
                    while(h<=t && qu[h].first+worker[i].L < j) h++;
                    if(h<=t) {
                        dp[i][j] = max(qu[h].second + j*worker[i].P,dp[i][j]);
                    }
                }
            }
        }
        printf("%lld\n",dp[k][n]);
    }
    return 0;
}

以后还是尽量使用数组模拟吧。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值