【BZOJ1688/POJ2436】Disease Management

56 篇文章 0 订阅
18 篇文章 0 订阅

                                           Disease Management

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5136 Accepted: 2430

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible. If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the milk.

Input

* Line 1: Three space-separated integers: N, D, and K

* Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0.

Output

* Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2
0
1 1
1 2
1 3
2 2 1
2 2 1

Sample Output

5

Hint

OUTPUT DETAILS:

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two diseases (#1 and #2), which is no greater than K (2).

 

解析:

       状压。。。

 

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

int state[1<<15],ans,n,m,k,ed;

int main()
{
	scanf("%d%d%d",&n,&m,&k),ed=(1<<(m+1))-1;
	for(int i=1;i<=n;i++)
	{
	  int l;scanf("%d",&l);
	  while(l--)
	  {
	  	int x;scanf("%d",&x);
	    state[i]|=(1<<x);
	  }
	}
	for(int i=0;i<=ed;i++)
	{
	  int sum=0;
	  for(int j=i;j;j-=j&(-j)) sum++;
	  if(sum>k) continue;
	  sum=0;
	  for(int j=1;j<=n;j++) if((state[j]&i)==state[j]) sum++;
	  ans=max(ans,sum);
	  if(ans==7) {cout<<i<<"!\n";break;}
	}
	cout<<ans;
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值