最短路 poj 3268 Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

最短路dijsktra,从目的点s总作为单源最短路的起点。将各边反转存入新的图中,即可模拟各点到s的情况。两次dijskra即可求出两次的最短路,最后比较。我利用了优优化了dij。

其中遇到一个玄学问题请大家指教。一共一千个点,dis数组范围开到8500以上才能过,否则就会一直wa,但是虽然开大了数组范围,没有初始化增大那部分dis[i]为无穷大,就ac了,感觉十分不合理。很疑惑dis数组范围怎么回事

以下ac代码

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<iostream>
//#include<random>
#include<functional>
#include<list>
#include<cstdlib>
#include<stdlib.h>
#include<vector>
#define lld long long int
#define INF 0x7fffffff
using namespace std;
/*
玄学问题,数组范围比预想的开大十倍
*/
typedef pair<int, int> P;
vector<P> G1[1005],G2[1005];
int dis1[10500];
int dis2[10500];
int n, m, x;

void dijkstra(int s) {
//  for (int i = 1;i <= n;i++)
//      dis1[i] = INF;
    fill(dis1, dis1 + 1005, INF);
    priority_queue<P, vector<P>, greater<P> > q;
    dis1[s] = 0;
    q.push(P(dis1[s],s));
    while (!q.empty())
    {
        int now = q.top().second;
        q.pop();
        for (int i = 0;i < G1[now].size();i++)
        {
            int v = G1[now][i].first;
            if (dis1[v] > dis1[now] + G1[now][i].second)
            {
                dis1[v] = dis1[now] + G1[now][i].second;
                q.push(P(dis1[v], v));
            }
        }
    }
}

void dijkstra2(int s) {
    //for (int i = 1;i <= n;i++)
        //dis2[i] = INF;
    fill(dis2, dis2 + 1005, INF);
    priority_queue<P, vector<P>, greater<P> > Q;
    dis2[s] = 0;
    Q.push(P(dis2[s], s));
    while (!Q.empty())
    {
        int now = Q.top().second;
        Q.pop();
        for (int i = 0;i < G2[now].size();i++)
        {
            int v = G2[now][i].first;
            if (dis2[v] > dis2[now] + G2[now][i].second)
            {
                dis2[v] = dis2[now] + G2[now][i].second;
                Q.push(P(dis2[v], v));
            }
        }
    }
}
int main()
{
    while (~scanf("%d%d%d", &n, &m, &x))
    {
        --x;
        for (int i = 0;i < m;i++)
        {
            G1[i].clear();G2[i].clear();
        }
        for (int i = 0;i < m;i++)
        {
            int a, b, t;
            scanf("%d%d%d", &a, &b, &t);
            --a;--b;
            G1[a].push_back(P(b, t));
            G2[b].push_back(P(a, t));
        }
        dijkstra(x);
        dijkstra2(x);
        int maxn = 0;
        for (int i = 0;i < n;i++)
        {
            if (maxn <  dis1[i] + dis2[i])
                maxn = dis1[i] + dis2[i];
        }
        printf("%d\n", maxn);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值