完美立方

A-完美立方

题目介绍:

For hundreds of years Fermat’s Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the “perfect cube” equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

Input:
One integer N (N <= 100).

Output:
The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

Sample Input:
24

Sample Output:
Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)

题目解析:

这道题目对于大家来说都是一道比较基础的暴力算法题,大多数的人在考到这道题目后都会采取暴力算法解题。这个思路我觉得没错,这道题也确实是暴力解决比较方便。但是如果可以更加优雅的(节省没必要的空间与时间)就更好了。问题便在于怎么去除没必要去排除的可能了。话不多说,代码献上。

过测代码:

#include <stdio.h>
int main()
{
    int n;
    scanf("%d",&n);
    for (int i=6; i<=n; i++)
        for(int i1=2; i1<i; i1++)
            for (int i2=i1; i2<i; i2++)
                for (int i3=i2; i3<i; i3++)
                    if (i*i*i==i1*i1*i1+i2*i2*i2+i3*i3*i3) 
					printf ("Cube = %d, Triple = (%d,%d,%d)\n",i,i1,i2,i3);
    return 0;
}//上述代码无误; 

## 补充:
这道题比较基础,但是在oj过测时也可能会不能通过,大多数还是空格与换行问题,下面献上错误代码以供参考。

## 未过测代码:

#include <stdio.h>
int main()
{
	int N;
	scanf("%d",&N);
	//int a,b,c,d;
	for(int a=6;a<=N;a++)
	{
		for(int b=2;b<a;b++)
		{
			for(int c=b;c<a;c++)
			{
				for(int d=c;d<a;d++)
				{
					if(a*a*a==b*b*b+c*c*c+d*d*d)
					{
						printf("Cube=%d,Triple=(%d,%d,%d)\n",a,b,c,d);
					}
				}
			}
		}
	}
	return 0;
 } //代码存在Presentation Error

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值