pat 2020秋 第二题

400 300 200 500 400 300 200 200 200 300

7-2

How Many Ways to Buy a Piece of Land

(25分)

The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: NNN (≤104\le 10^4≤10​4​​), the number of pieces of the land (hence the land pieces are numbered from 1 to NNN in order), and MMM (≤109\le 10^9≤10​9​​), the amount of money that your customer has.

Then in the next line, NNN positive integers are given, where the iii-th one is the price of the iii-th piece of the land.

It is guaranteed that the total price of the land is no more than 10910^910​9​​.

Output Specification:

For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.

Sample Input:

5 85
38 42 15 24 9

Sample Output:

11

Hint:

The 11 different ways are:

38
42
15
24
9
38 42
42 15
42 15 24
15 24
15 24 9
24 9

可以直接 for循环但会超时

dfs 可以剪枝 因为连续的相当于一条单链,不设置空阶段

注意边界参数的设置 起点+长度-1  才是最终节点的位置 

#include<bits/stdc++.h>
using namespace std;
vector<int>aa;
//一开始要把第一个节点囊括进去 
int ans=0;
void dfs(int root,int top,int cnt,int sum){
	//end
	if(root==cnt&&sum<=top){
	ans++;
	return;	
	} 
	if(root>cnt||sum>top) return;//可以在过程中剪枝可行性剪枝 最优行剪枝 
	
	dfs(root+1,top,cnt,sum+aa[root+1]);
	//debug
//	printf("%d",root+1);
}
int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	aa.resize(n);
	for(int i=0;i<n;i++){
		scanf("%d",&aa[i]);
	}
	for(int i=1;i<=n;i++){
		for(int j=0;j+i-1<n;j++){//会有出去的那一刻 
			dfs(j,m,j+i-1,aa[j]);//参数设置 以j为起点 个数包括本身  以第一个元素为起点加一整个长度自然多一个 
		}
	}
	printf("%d",ans);
	return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值