【C++编程基础】AOJ (C++ Programming II)—4-D-unique

4-D-unique

题目

Unique For a sequence of integers A={a0,a1,…,an−1} which is sorted by ascending order, eliminate all equivalent elements.
输入
A sequence is given in the following format.
n
a0 a1…,an−1
输出
Print the sequence after eliminating equivalent elements in a line. Separate adjacency elements by a space character.
样例输入
4
1 2 2 4
样例输出
1 2 4

题解(代码流程)

#include<bits/stdc++.h>
#include<iostream>
using namespace std;

int main() {
    ios::sync_with_stdio(false);
    cin.tie(nullptr);
    cout.tie(nullptr);
    int n;
    cin >> n;
    vector<int> A(n);
    for (int i = 0; i < n; i++)cin >> A[i];
    auto p = unique(A.begin(), A.end());//定义自动变量p,调用查重函数unique
    for (int i = 0; i < p - A.begin(); i++) {//输出查重后,不重复的元素
        cout << A[i] << " ";
    }
    cout << endl;
    return 0;
}

小结

学会运用unique函数来查重

unique(A.begin(), A.end())

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值