HDU:1016 Prime Ring Problem

这是一个关于构建满足相邻两圈数字之和为素数的圆环的问题。输入是圆环的圈数n,需要输出符合条件的排列。题目要求使用深度优先搜索(DFS)解决,并按字典序输出结果。原代码尝试通过选择性交换排序实现,但未成功,修正后的DFS代码能够正确生成满足条件的排列。注意,使用next_permutation会因时间复杂度过高而导致超时。
摘要由CSDN通过智能技术生成

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1: 
1 4 3 2 5 6 
1 6 5 2 3 4 

Case 2:
1 2 3 8 5 6 7 4 
1 2 5 8 3 4 7 6 
1 4 7 6 5 8 3 2 
1 6 7 4 3 8 5 2

思路

典型的深度搜索(dfs)问题
开始我dfs采用的思路是选择性交换排序,

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>

using namespace std;

int isprime[55];
int n, vis[55];
int a[55];

void isPrime()
{
	int i, j;
	for (i = 0; i < 55; ++i)
	{
		isprime[i] = 1;
	}
	isprime[0] = isprime[1] = 0;
	for (i = 2; i <= 7; ++i)
	{
		if (isprime[i])
		{
			for (j = i * i; j <= 50; j += i)
			{
				isprime[j] = 0;
			}
		}
	}
}

void init()
{
	int i;
	for (i = 0; i < n; ++i)
	{
		a[i] = i + 1;
	}
}


bool check(int k)
{
	if (isprime[a[k % n] + a[k - 1]])
		return true;
	return false;
}

void dfs(int k)
{
	int i;
	int temp;
	if (k == n)
	{
		if (check(k))
		{
			for (i = 0; i < n - 1; ++i)
				printf("%d ", a[i]);
			printf("%d\n", a[i]);
		}
	}
	for (i = k; i < n; ++i)
	{
		{
			temp = a[i];
			a[i] = a[k];
			a[k] = temp;
			if (check(k))
				dfs(k + 1);
			temp = a[i];
			a[i] = a[k];
			a[k] = temp;
		}
	}
}


int main()
{
	int ans = 0;
	int i;
	isPrime();
	while (cin >> n)
	{
		init();
		printf("Case %d:\n", ++ans);
		dfs(1);
		printf("\n");
	}
	return 0;
}

由于这种交换的dfs没有按照字典序将顺序输出,故出错
经过改进的代码是这样的

#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

int isprime[55];
int n, vis[55];
int a[55];

void isPrime() //筛选法找素数
{
	int i, j;
	for (i = 0; i < 55; ++i)
	{
		isprime[i] = 1;
	}
	isprime[0] = isprime[1] = 0;
	for (i = 2; i <= 7; ++i)
	{
		if (isprime[i])
		{
			for (j = i * i; j <= 50; j += i)
			{
				isprime[j] = 0;
			}
		}
	}
}

void dfs(int k) //找到位置
{
	int i;
	if (k == n && isprime[a[n - 1] + a[0]])
	{
		for (i = 0; i < n - 1; ++i)  //按照顺序向空位填数字
		{
			printf("%d ", a[i]);
		}
		printf("%d\n", a[i]);
	}
	else if (k < n)
	{
		for (i = 2; i <= n; ++i)
		{
			if (!vis[i] && isprime[i + a[k - 1]])
			{
				vis[i] = 1;
				a[k] = i;
				dfs(k + 1);
				vis[i] = 0;
			}
		}
	}
}

int main()
{
	int ans = 0;
	isPrime();
	a[0] = 1;
	while (cin >> n)
	{
		printf("Case %d:\n", ++ans);
		dfs(1);
		printf("\n");
	}
	return 0;
}

运行的前十个结果

1
Case 1:
1

2
Case 2:
1 2

3
Case 3:

4
Case 4:
1 2 3 4
1 4 3 2

5
Case 5:

6
Case 6:
1 4 3 2 5 6
1 6 5 2 3 4

7
Case 7:

8
Case 8:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

9
Case 9:

10
Case 10:
1 2 3 4 7 6 5 8 9 10
1 2 3 4 7 10 9 8 5 6
1 2 3 4 9 8 5 6 7 10
1 2 3 8 5 6 7 4 9 10
1 2 3 8 5 6 7 10 9 4
1 2 3 10 7 4 9 8 5 6
1 2 3 10 7 6 5 8 9 4
1 2 3 10 9 8 5 6 7 4
1 2 5 6 7 4 3 8 9 10
1 2 5 6 7 4 9 8 3 10
1 2 5 6 7 10 3 8 9 4
1 2 5 6 7 10 9 8 3 4
1 2 5 8 3 4 9 10 7 6
1 2 5 8 3 10 9 4 7 6
1 2 5 8 9 4 3 10 7 6
1 2 5 8 9 10 3 4 7 6
1 2 9 4 3 8 5 6 7 10
1 2 9 4 7 6 5 8 3 10
1 2 9 4 7 10 3 8 5 6
1 2 9 8 5 6 7 4 3 10
1 2 9 8 5 6 7 10 3 4
1 2 9 10 3 8 5 6 7 4
1 2 9 10 7 4 3 8 5 6
1 2 9 10 7 6 5 8 3 4
1 4 3 2 5 8 9 10 7 6
1 4 3 2 9 8 5 6 7 10
1 4 3 8 5 2 9 10 7 6
1 4 3 8 5 6 7 10 9 2
1 4 3 8 9 2 5 6 7 10
1 4 3 8 9 10 7 6 5 2
1 4 3 10 7 6 5 8 9 2
1 4 7 6 5 2 3 8 9 10
1 4 7 6 5 2 9 8 3 10
1 4 7 6 5 8 3 2 9 10
1 4 7 6 5 8 3 10 9 2
1 4 7 6 5 8 9 2 3 10
1 4 7 6 5 8 9 10 3 2
1 4 7 10 3 2 9 8 5 6
1 4 7 10 3 8 9 2 5 6
1 4 7 10 9 2 3 8 5 6
1 4 7 10 9 8 3 2 5 6
1 4 9 2 3 8 5 6 7 10
1 4 9 2 5 8 3 10 7 6
1 4 9 8 3 2 5 6 7 10
1 4 9 8 3 10 7 6 5 2
1 4 9 8 5 2 3 10 7 6
1 4 9 8 5 6 7 10 3 2
1 4 9 10 7 6 5 8 3 2
1 6 5 2 3 8 9 4 7 10
1 6 5 2 3 8 9 10 7 4
1 6 5 2 9 8 3 4 7 10
1 6 5 2 9 8 3 10 7 4
1 6 5 8 3 2 9 4 7 10
1 6 5 8 3 2 9 10 7 4
1 6 5 8 3 4 7 10 9 2
1 6 5 8 3 10 7 4 9 2
1 6 5 8 9 2 3 4 7 10
1 6 5 8 9 2 3 10 7 4
1 6 5 8 9 4 7 10 3 2
1 6 5 8 9 10 7 4 3 2
1 6 7 4 3 2 5 8 9 10
1 6 7 4 3 8 5 2 9 10
1 6 7 4 3 10 9 8 5 2
1 6 7 4 9 2 5 8 3 10
1 6 7 4 9 8 5 2 3 10
1 6 7 4 9 10 3 8 5 2
1 6 7 10 3 2 5 8 9 4
1 6 7 10 3 4 9 8 5 2
1 6 7 10 3 8 5 2 9 4
1 6 7 10 9 2 5 8 3 4
1 6 7 10 9 4 3 8 5 2
1 6 7 10 9 8 5 2 3 4
1 10 3 2 5 8 9 4 7 6
1 10 3 2 9 8 5 6 7 4
1 10 3 4 7 6 5 8 9 2
1 10 3 8 5 2 9 4 7 6
1 10 3 8 5 6 7 4 9 2
1 10 3 8 9 2 5 6 7 4
1 10 3 8 9 4 7 6 5 2
1 10 7 4 3 2 9 8 5 6
1 10 7 4 3 8 9 2 5 6
1 10 7 4 9 2 3 8 5 6
1 10 7 4 9 8 3 2 5 6
1 10 7 6 5 2 3 8 9 4
1 10 7 6 5 2 9 8 3 4
1 10 7 6 5 8 3 2 9 4
1 10 7 6 5 8 3 4 9 2
1 10 7 6 5 8 9 2 3 4
1 10 7 6 5 8 9 4 3 2
1 10 9 2 3 8 5 6 7 4
1 10 9 2 5 8 3 4 7 6
1 10 9 4 7 6 5 8 3 2
1 10 9 8 3 2 5 6 7 4
1 10 9 8 3 4 7 6 5 2
1 10 9 8 5 2 3 4 7 6
1 10 9 8 5 6 7 4 3 2


补充说明

本题目如果用next_permutation(a=1,a+n)来写会超时,因为全排列函数虽然是按照字典序输出,但是它纯粹是将所有的情况列举出来,中间没有判断和回溯的过程,故用的时间会比dfs的时间长很多,

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值