hdu1016:Prime Ring Problem

原题链接

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47623    Accepted Submission(s): 21048


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1072  1242  1175  1253  1181 



题意: 
给你一个整数n, 求解1~n排列成环使得每相邻的两个数相加是素数的所有情况。

解题思路: DFS
DFS从x = 1开始深搜, 每次找到符合条件的两个数就加入数组a,当满足x == n 并且a[x] + a[1] 也是素数时结束, 并输出a数组。

代码:
#include <cmath>
#include <string>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LOCAL
using namespace std;

int n;
int a[105];
int visit[105];
int is_prime[105];

void f()              //素数打表, 也可直接写入前40个素数入该数组
{
    for (int i = 2; i <= 10; i++)
        if(!is_prime[i])
            for (int j = i+i; j <= 100; j+=i)
                is_prime[j] = 1;
}

void dfs(int x)
{
    if(x == n && !is_prime[a[x]+a[1]])  //满足条件并输出
    {
        for (int i = 1; i < n; i++)
            printf("%d ",a[i]);
        printf("%d\n", a[x]);
    }
    else
    {
        for (int i = 2; i <= n; i++)
        {
            if(!visit[i])                   //判断是否访问过
            {
                if(!is_prime[i + a[x]])     //判断i是否符合当前条件
                {
                    visit[i] = 1;       //标记已访问
                    a[++x] = i;         //i加入a数组
                    dfs(x);
                    x--;                //退一格
                    visit[i] = 0;       //取消标记,以便之后DFS
                }
            }
        }
    }
}


int main()
{
//    #ifdef LOCAL
//    freopen("data.in", "r", stdin);
//    freopen("data.out", "w", stdout);
//    #endif
    f();
    int z = 1;
    while (scanf("%d", &n) != EOF)
    {
        memset(visit, 0, sizeof(visit));

        a[1] = 1;                   //初始时从1开始
        visit[1] = 1;               //标记1已经走过,虽然并不会影响。
        printf("Case %d:\n", z++);
        dfs(1);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值