Sticks(递归回溯好题)

Sticks

题目传送门

Time Limit: 1000MS Memory Limit: 10000K
Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output should contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5

AC代码:

#include<iostream>
#include<algorithm>

using namespace std;
const int maxn = 65;
int a[maxn], n, len;
bool used[maxn];
bool flag = false;

bool cmp(int a, int b)
{
	return a > b;
}

bool dfs(int i, int l, int t)
{
	int j;
	if (l == 0)
	{
		t -= len;
		if (t == 0)
			return true;
		for (j = 0; used[j]; ++j);
		used[j] = 1;
		if (dfs(j + 1, len - a[j], t))
			return true;
		used[j] = false; t += len;
	}
	for (j = i; j < n; ++j)
	{
		if (j > 0 && (a[j] == a[j - 1]) && !used[j - 1])
			continue;
		if (!used[j] && a[j] <= l)
		{
			l -= a[j];
			used[j] = true;
			if (dfs(j, l, t))
				return true;
			l += a[j];
			used[j] = false;
			if (a[j] == l)
				break;
		}
	}
	return false;
}

int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	int i, j;
	int sum = 0;
	while (cin >> n, n != 0)
	{
		sum = 0; flag = false;
		for (i = 0; i < n; ++i)
		{
			cin >> a[i]; used[i] = false;
			sum += a[i];
		}
		sort(a, a + n, cmp);
		for (len = a[0]; len <= sum / 2; ++len)
		{
			if (sum % len == 0)
			{
				if (dfs(0, len, sum))
				{
					flag = true;
					cout << len << endl;
					break;
				}
			}
		}
		if (!flag)
			cout << sum << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值