数组模拟栈

实现一个栈,栈初始为空,支持四种操作:

(1) “push x” – 向栈顶插入一个数x;

(2) “pop” – 从栈顶弹出一个数;

(3) “empty” – 判断栈是否为空;

(4) “query” – 查询栈顶元素。

现在要对栈进行M个操作,其中的每个操作3和操作4都要输出相应的结果。

输入格式
第一行包含整数M,表示操作次数。

接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种。

输出格式
对于每个”empty”和”query”操作都要输出一个查询结果,每个结果占一行。

其中,”empty”操作的查询结果为“YES”或“NO”,”query”操作的查询结果为一个整数,表示栈顶元素的值。

数据范围
1≤M≤100000,
1≤x≤109
所有操作保证合法。

输入样例:

10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty

输出样例:

5
5
YES
4
NO

解题代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>

using namespace std;

const int N = 100010;
int stk[N];
int tt;
int idx;
int x;
int n;
string s;

void init ()
{
	tt = 0;
}


void stack_pop()
{
	tt--;
}

void stack_push(int x)
{
	tt++;
	stk[tt] = x;
	
}

int stack_empty()
{
	return tt;
}

int stack_query()
{
	return stk[tt];
}

int main()
{
	cin >> n;
	
	init ();
	
	while(n --)
	{
		cin >> s;
		if(s == "push")
		{
			cin >> x;
			stack_push(x);
		}
		else if(s == "query")
		{
			cout << stack_query() << endl;
		}
		
		else if(s == "pop")
		{
			stack_pop();
		}
		
		else
		{
			if(!stack_empty()) cout << "YES" << endl; 
			else cout << "NO" << endl;
		}
	}
 } 

题目链接: https://www.acwing.com/problem/content/830/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值