寒假集训_专题一题解_D - DFS(HDU - 2660)

题目

Accepted Necklace
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won’t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.

Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.

Output
For each case, output the highest possible value of the necklace.

Sample Input
1
2 1
1 1
1 1
3

Sample Output
1

题目大意

有n件物品,在其中选k件,每件有其重量和价值,求选的物品的在重量和不超过W时价值和的最大值

题解

直接dfs一遍即可

代码

#include <iostream>
#include <cstring>
using namespace std;
int w[50],p[50],k,W,ans,n;
void dfs(int u,int now,int price,int weight)
{
	if(u == k)
	{
		ans = max(price,ans);
		return;
	}
	if(n-now+u < k)return;//剪枝
	dfs(u,now + 1,price,weight);
	if(weight+w[now+1] <= W)
		dfs(u+1,now+1,price+p[now+1],weight+w[now+1]);
}
int main()
{
	int T;
	cin >> T;
	while(T--)
	{
		ans = -1;
		scanf("%d%d", &n, &k);
		for(int i = 1; i <= n; i ++)
			scanf("%d%d",&p[i],&w[i]);
		 scanf("%d", &W);
		 dfs(0,0,0,0);
		 printf("%d\n",ans);
	} 
	return 0;
 } 

注意点

1.如果剩下的都选都不能满足选k个时,可剪枝

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值