HDU1010 Tempter of the Bone(DFS奇偶剪枝)

传送门

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0

Sample Output

NO
YES

题意: 从图中的S点出发,'X’为不通过,经过的点不可返回,要求在时间t时刚好到达出口D,如果可以输出YES,否则输出NO
题解: 稍稍棘手了一些,需要在DFS函数里稍做一些“手脚”:

  1. 允许原路返回,因为一般的DFS我们是没办法控制在哪个时间点到达出口的,只不过是一种暴力遍历而已,如果发现这条路径无法刚好在时间t到达出口,那我们将原路返回,记得将访问标记数组重置为0。
for (int i = 0; i < 4; i++){
        int nx = x + dir[i][0];
        int ny = y + dir[i][1];
        if(jud(nx,ny)){
            dfs(nx, ny, s+1);
            vis[nx][ny] = 0;//选择一条路走完以后重新回到这个点,标记为未访问
            if(flag)    return;
        }
    }
  1. 剪枝:如果起点与终点间的曼哈顿距离(横向距离+纵向距离)已经超过时间t,那就已经失去遍历的必要了。其次便是既是改变路线,固定起点到固定终点所花费的时间其奇偶性都相同,所以如果一开始曼哈顿距离与时间t的奇偶性不同,也没有遍历的必要了。
if(abs(sx-dx)+abs(sy-dy)>t || (sx+dx+sy+dy+t)%2==1){
    printf("NO\n");
    continue;
}
  1. 然后要注意的就是实际上能否在规定时间到达出口,递归途中,规定时间到达但未到出口,就不必再遍历了;如果在规定时间到达出口,标记以后结束所有递归。
if(flag)    return;//已经找到过出口,后续递归全部结束
    if(x==dx && y==dy){//是出口,且恰好时间符合
        if(s==t)    flag = 1;
        return;
    }
    if(s >= t){//到达指定时间但没到达出口
        flag = 0;
        return;
    }

大概的要点应该就是这些,与常规题目稍有不同,需要灵活变动;以及坑了我很久很久的地方,存图!这两个getchar()的位置属实有恶心到我,我一开把他们合并在第二个for的前面,没想到还是影响存图了,以后每次都应该输出确认一下的。

	getchar();
    for (int i = 1; i <= n; i++){
        for (int j = 1; j <= m; j++){
            scanf("%c", mp[i] + j);
            vis[i][j] = 0;
            if(mp[i][j] == 'S')
                sx = i, sy = j;
            else if(mp[i][j] == 'D')
                dx = i, dy = j;
        }
        getchar();
    }

下面是完整代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;

int flag;
int n, m, t;
int sx, sy, dx, dy;
int vis[8][8];//访问标记
char mp[8][8];//存图
int dir[][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};

int jud(int x, int y){//判断是否越界、是否访问过、是否可行
    if(x<1 || x>n || y<1 || y>m)
        return 0;
    if(mp[x][y] == 'X' || vis[x][y])
        return 0;
    return 1;
}

void dfs(int x, int y, int s){
    vis[x][y] = 1;
    if(flag)    return;//已经找到过出口,后续递归全部结束
    if(x==dx && y==dy){//是出口,且恰好时间符合
        if(s==t)    flag = 1;
        return;
    }
    if(s >= t){//到达指定时间但没到达出口
        flag = 0;
        return;
    }
    for (int i = 0; i < 4; i++){
        int nx = x + dir[i][0];
        int ny = y + dir[i][1];
        if(jud(nx,ny)){
            dfs(nx, ny, s+1);
            vis[nx][ny] = 0;//选择一条路走完以后重新回到这个点,标记为未访问
            if(flag)    return;
        }
    }
}

int main(){
    while(~scanf("%d%d%d", &n, &m, &t) &&( n|| m|| t)){
        getchar();
        for (int i = 1; i <= n; i++){
            for (int j = 1; j <= m; j++){
                scanf("%c", mp[i] + j);
                vis[i][j] = 0;
                if(mp[i][j] == 'S')
                    sx = i, sy = j;
                else if(mp[i][j] == 'D')
                    dx = i, dy = j;
            }
            getchar();
        }

        if(abs(sx-dx)+abs(sy-dy)>t || (sx+dx+sy+dy+t)%2==1){
            printf("NO\n");
            continue;
        }
        flag = 0;
        dfs(sx, sy, 0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值