HDU 3016 Man Down——线段树

传送门
Problem Description
The Game “Man Down 100 floors” is an famous and interesting game.You can enjoy the game from
在这里插入图片描述
We take a simplified version of this game. We have only two kinds of planks. One kind of the planks contains food and the other one contains nails. And if the man falls on the plank which contains food his energy will increase but if he falls on the plank which contains nails his energy will decrease. The man can only fall down vertically .We assume that the energy he can increase is unlimited and no borders exist on the left and the right.

First the man has total energy 100 and stands on the topmost plank of all. Then he can choose to go left or right to fall down. If he falls down from the position (Xi,Yi),he will fall onto the nearest plank which satisfies (xl <= xi <= xr)(xl is the leftmost position of the plank and xr is the rightmost).If no planks satisfies that, the man will fall onto the floor and he finishes his mission. But if the man’s energy is below or equal to 0 , he will die and the game is Over.

Now give you the height and position of all planks. And ask you whether the man can falls onto the floor successfully. If he can, try to calculate the maximum energy he can own when he is on the floor.(Assuming that the floor is infinite and its height is 0,and all the planks are located at different height).

Input
There are multiple test cases.

For each test case, The first line contains one integer N (2 <= N <= 100,000) representing the number of planks.

Then following N lines representing N planks, each line contain 4 integers (h,xl,xr,value)(h > 0, 0 < xl < xr < 100,000, -1000 <= value <= 1000), h represents the plank’s height, xl is the leftmost position of the plank and xr is the rightmost position. Value represents the energy the man will increase by( if value > 0) or decrease by( if value < 0) when he falls onto this plank.

Output
If the man can falls onto the floor successfully just output the maximum energy he can own when he is on the floor. But if the man can not fall down onto the floor anyway ,just output “-1”(not including the quote)

Sample Input

4
10 5 10 10
5 3 6 -100
4 7 11 20
2 2 1000 10

Sample Output

140

题意: 人物具有100的初始分值,从最高的木板上可以选择左边或右边垂直往下跳,注意是垂直的(落地点的坐标与落下时的初始坐标相同),不同木板上具有不同的分值,输出到达地面时所能达到的最高分值;如果分值≤0,则输出-1.
题解: 我一开始真的被线段树的模板给限制住了,花了很长很长的时间在思考,我到底要怎么修改区间更新函数。此题特殊的在于,只能从某块木板的两端下落,下落之后人物又可以移动到下一块木板的两端,所以我真的真的不知道该怎么处理区间更新函数。直到吃完饭,我才反应过来,只要去判断木块两端下落之后分数的变动,然后取最大值,用这个最大值冲洗覆盖原先木板这个区间的分数值就可以了,相通之后其实是非常简单的。然后就是套模板了。

#include<iostream>
#include<algorithm>
using namespace std;
const int N = 100005;
typedef long long LL;

int n, q;
LL a[N];
LL  lazy[N << 2];
struct node{
    int h, l, r, c;
    friend bool operator<(const node &a, const node &b){
        return a.h < b.h;}
} plank[N];

struct Tree{
	int l, r;
	LL sum, max_sum;
	int mid(){	return (l + r) >> 1;}
}tree[N<<2];

void PushUp(int rt){ 
    tree[rt].max_sum = max(tree[rt << 1].max_sum, tree[rt << 1 | 1].max_sum);
}

void PushDown(int rt){
	if(lazy[rt]){
		lazy[rt << 1] = lazy[rt];
		lazy[rt << 1 | 1] = lazy[rt];
        tree[rt << 1].max_sum = lazy[rt];
        tree[rt << 1 | 1].max_sum = lazy[rt];
        lazy[rt] = 0;
	}
}

void build(int l, int r, int rt){
	tree[rt].l = l;
	tree[rt].r = r;
	lazy[rt] = 0;
	if (l == r)	{
		tree[rt].sum = tree[rt].max_sum = a[l];
        return;
	}
	int m = tree[rt].mid();
	
	build(l, m, (rt << 1));
	build(m + 1, r, (rt << 1 | 1));
	
	PushUp(rt);
}

void update(LL c, int l, int r, int rt){
	if(tree[rt].l==l && tree[rt].r==r){
		lazy[rt] = c;
        tree[rt].max_sum = c;//
        return;
	}
	 
	if(tree[rt].l == tree[rt].r)	return;
	
	int m = tree[rt].mid();
	PushDown(rt);
	if (r <= m)		update(c, l, r, rt << 1);
	else if(l > m)	update(c, l, r, rt << 1 | 1);
	else {
		update(c, l, m, rt << 1);
		update(c, m + 1, r, rt << 1 | 1);
    }
	PushUp(rt);
}


LL Max(int l, int r, int rt){//
	if (l==tree[rt].l && r==tree[rt].r)
		return tree[rt].max_sum;
	int m = tree[rt].mid(); 
	PushDown(rt);
	LL res = 0;
	if(r <= m)		res = Max(l, r, rt << 1);
	else if(l > m)	res = Max(l, r, rt << 1 | 1);
	else
        res = max(Max(l, m, rt << 1), Max(m + 1, r, rt << 1 | 1));
    return res;
}

int main(){
    while(~scanf("%d", &n)){
        for (int i = 1; i <= 100000; i++)
            a[i] = 100;
        build(1, 100000, 1);
        for (int i = 1; i <= n; i++)
            scanf("%d%d%d%d", &plank[i].h, &plank[i].l, &plank[i].r, &plank[i].c);
        sort(plank + 1, plank + n + 1);
        for (int i = 1; i <= n; i++){
			int l = plank[i].l, r = plank[i].r;
			LL c = plank[i].c;
			LL add = max(c + Max(l, l, 1), c + Max(r, r, 1));
			update(add, plank[i].l, plank[i].r, 1);
		}

		LL ans = Max(plank[n].l, plank[n].r, 1);
		if(ans>0)
			printf("%lld\n", ans);
		else
			printf("-1\n");
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值