PAT——A.1015—phone bills

原题目

1016 Phone Bills (25 分)
A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80\

中文翻译

长途电话公司按以下规则向客户收费:

拨打长途电话的费用为每分钟一定的费用,具体取决于拨打电话的时间。当客户开始拨打长途电话时,时间会被记录下来,客户挂断电话的时间也会被记录下来。每个日历月,都会向客户发送每分钟呼叫的帐单(按一天中的时间确定的费率)。你的工作是根据一组电话记录准备每个月的账单。

输入规格:
每个输入文件包含一个测试用例。每个案例都有两部分:费率结构和电话记录。

费率结构由一行 24 个非负整数组成,表示 00:00 - 01:00 的通行费(美分/分钟)、01:00 - 02:00 的通行费,以此类推,以此类推.

下一行包含一个正数 N (≤1000), 其次是 N行记录。每条电话记录均由客户姓名(最多 20 个字符的字符串,不含空格)、时间和日期 ( MM:dd:HH:mm) 以及单词on-lineor 组成off-line。

对于每个测试用例,所有日期都将在一个月内。每条on-line记录都与同一客户的按时间顺序排列的下一条off-line记录配对,前提是它是一条记录。任何on-line未与配对记录off-line记录被忽略,因为是off-line不具有配对记录on-line的记录。保证至少有一个调用在输入中配对良好。您可以假设同一客户的任何两条记录都没有相同的时间。时间记录使用 24 小时制。

输出规格:
对于每个测试用例,您必须为每个客户打印电话帐单。

账单必须按客户姓名的字母顺序打印。对于每个客户,首先以示例所示的格式将客户姓名和账单月份打印在一行中。然后对于通话的每个时间段,在一行中打印开始和结束时间和日期 ( dd:HH:mm)、持续时间(以分钟为单位)和通话费用。呼叫必须按时间顺序列出。最后,以示例所示的格式打印当月的总费用。

样本输入:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
示例输出:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;


int toll[25];

typedef struct Record
{
    char name[25];
    int month,dd,hh,mm;
    bool status;
}Rec;
Rec temp;
Rec rec[1010];

bool cmp(Record a,Record b)
{
    int s=strcmp(a.name,b.name);
    if(s!=0)
        return s<0;
    else if(a.month!=b.month)
        return a.month<b.month;
    else if(a.dd!=b.dd)
        return a.dd<b.dd;
    else if(a.hh!=b.hh)
        return a.hh<b.hh;
    else
        return a.mm<b.mm;
}

void get_cost(int on,int off,int &time,int &money)
{
    temp=rec[on];
    while(temp.dd<rec[off].dd || temp.hh <rec[off].hh || temp.mm<rec[off].mm)
    {
        time++;
        money+=toll[temp.hh];
        temp.mm++;
        if(temp.mm>=60)
        {
            temp.mm=0;
            temp.hh++;
        }
        if(temp.hh>=24)
        {
            temp.hh=0;
            temp.dd++;
        }
    }
}

int main()
{
    int i,n;
    for(i=0;i<24;i++)
        cin>>toll[i];
    cin>>n;
    char line[10];
    for(i=0;i<n;i++)
    {
        scanf("%s",rec[i].name);
        scanf("%d:%d:%d:%d",&rec[i].month,&rec[i].dd,&rec[i].hh,&rec[i].mm);
        scanf("%s",line);
        if(strcmp(line,"on-line")==0)
            rec[i].status=true;
        else
            rec[i].status=false;
    }

    sort(rec,rec+n,cmp);
    int on=0;
    int off,next;
    while(on<n)
    {
        int needprint;
        needprint=0;
        next=on;
        while(next<n && strcmp(rec[next].name,rec[on].name)==0)
        {
            if(needprint==0 && rec[next].status==true)
                needprint=1;
            else if(needprint==1 && rec[next].status==false)
                needprint=2;
            next++;
        }
        if(needprint<2)
        {
            on=next;
            continue;
        }
        int allMoney=0;
        printf("%s %02d\n",rec[on].name,rec[on].month);
        while(on<next)
        {
            while(on<next-1 && !(rec[on].status==true&&rec[on+1].status==false))
                on++;
            off=on+1;
            if(off==next)
            {
                on=next;
                break;
            }
            printf("%02d:%02d:%02d ",rec[on].dd,rec[on].hh,rec[on].mm);
            printf("%02d:%02d:%02d ",rec[off].dd,rec[off].hh,rec[off].mm);
            int time=0;
            int money=0;
            get_cost(on,off,time,money);
            allMoney+=money;
            printf("%d $%.2f\n",time,money/100.0);
            on=off+1;
        }
        printf("Total amount: $%.2f\n",allMoney/100.0);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值