【PAT A1025】PAT Ranking 附带翻译

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大致翻译:

编程能力测试(PAT)由浙江大学计算机科学与技术学院主办。每个测试应该同时在几个考场进行,并且在测试之后,排名列表将立即被合并。现在,你的工作是编写一个程序来正确地合并所有的排名列表,并生成最终的排名。

输入格式:

每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正数N(≤100),即考场的数量。然后是N个排名列表,每个排名列表的第一行包含一个正整数K(≤300),即被测试者的数量,然后是K行包含注册号(13位数字)和每个被测试者的总分。一行中的所有数字都用空格隔开。

输出格式:

对于每个测试用例,首先在一行中打印被测试者的总数。然后按如下格式打印最终的排名:
registration_number final_rank location_number local_rank
(登记号码 最终排名 考场编号 考场内排名)
位置编号从1到n。输出必须按最终排名的非递减顺序排序。具有相同分数的被试必须具有相同的排名,输出必须按其注册号的非降序排列。

样例输入:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

样例输出:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Student{
	char id[15];
	int score;
	int location_number;
	int local_rank;
	int final_rank;//有其他方法可以不需要记录最终排名,直接输出排名
}stu[300010];
bool cmp(Student a,Student b){
	if(a.score!=b.score) return a.score>b.score;
	else return strcmp(a.id,b.id)<0;
}
int main(){
	int N,K,n=0;//N为考场数,K为考场内学生数,n为学生总数
	scanf("%d",&N);
	for(int i=1;i<=N;i++){
		scanf("%d",&K);
		for(int j=1;j<=K;j++){
			scanf("%s %d",stu[n].id,&stu[n].score);
			stu[n].location_number=i;
			n++;
		}
		sort(stu+n-K,stu+n,cmp);
		stu[n-K].local_rank=1;
		for(int m=n-K+1;m<n;m++){
			if(stu[m].score==stu[m-1].score) stu[m].local_rank=stu[m-1].local_rank;
			else stu[m].local_rank=K+m-n+1;
		}
	}
	printf("%d\n",n);
	sort(stu,stu+n,cmp);
	stu[0].final_rank=1;
	for(int i=1;i<n;i++){
		if(stu[i].score==stu[i-1].score) stu[i].final_rank=stu[i-1].final_rank;
		else stu[i].final_rank=i+1;
	}
	for(int i=0;i<n;i++){
		printf("%s ",stu[i].id);
		printf("%d %d %d\n",stu[i].final_rank,stu[i].location_number,stu[i].local_rank);
	}
		return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值