C - A Simple Problem with Integers

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.OutputYou need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output
4
55
9
15

题意
一组数据,给出每次变化,求x-y的和

解题思路
区间修改,区间求和

代码

#include<iostream>
#define lowbit(x) x&-x
#define maxn 100010
#define ll long long
using namespace std;
int  n,m,l,r,x;
ll c[maxn],b1[maxn],b2[maxn],Sum,y;//加和可能会爆出int型
char a;
void update(ll a[],int p,ll x)//修改
{
	while(p<=n)
	{
		a[p]+=x;
		p+=lowbit(p);
	}
}
ll sum(ll a[],int p)//查询前缀和
{
	Sum=0;
	while(p>0)
	{
		Sum+=a[p];
		p-=lowbit(p);
	}
	return Sum;
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%lld",&y);
		c[i]=c[i-1]+y;
	}
	for(int i=0;i<m;i++)
	{
		getchar();
		scanf("%c",&a);
		if(a=='Q')
		{
			scanf("%d%d",&l,&r);//查询区间和
			ll suml=c[l-1]+l*sum(b1,l-1)-sum(b2,l-1);
			ll sumr=c[r]+(r+1)*sum(b1,r)-sum(b2,r);
			printf("%lld\n",sumr-suml);
		}
		else if(a=='C')
		{
			scanf("%d%d%d",&l,&r,&x);
			update(b1,l,x);//b1:前缀和
			update(b1,r+1,-x);
			update(b2,l,x*l);//b2:*i的前缀和
			update(b2,r+1,-x*(r+1));
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值