☆1003. Emergency (25) [Dijkstra算法]

1003. Emergency (25) [Dijkstra算法]
As an emergency rescue team leader of a city, you are given a special map of your country. The map
shows several scattered cities connected by some roads. Amount of rescue teams in each city and the
length of each road between any pair of cities are marked on the map. When there is an emergency call
to you from some other city, your job is to lead your men to the place as quickly as possible, and at the

mean time, call up as many hands on the way as possible.


Input
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<=
500) – the number of cities (and the cities are numbered from 0 to N-1), M – the number of roads, C1 and
C2 – the cities that you are currently in and that you must save, respectively. The next line contains N
integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each
describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the
length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.


Output
For each test case, print in one line two numbers: the number of diferent shortest paths between C1 and
C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at
the end of a line.


Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1


Sample Output
2 4


题⽬⼤意:n个城市m条路,每个城市有救援⼩组,所有的边的边权已知。给定起点和终点,求从起点
到终点的最短路径条数以及最短路径上的救援⼩组数⽬之和。如果有多条就输出点权(城市救援⼩组
数⽬)最⼤的那个

 

解:用Dijkstra算法,解析,代码里有很多注释,理解该算法的同学应该很容易看懂了~

#include <iostream>
#include <algorithm>
using namespace std;

int n, m, c1, c2;
//dis[i]表示从出发点到i结点最短路径的路径⻓度,num[i]表示从出发点到i结点最短路径的条数
//w[i]表示从出发点到i点救援队的数⽬之和
int e[510][510], weight[510], dis[510], num[510], w[510];
bool visit[510];//标记顶点
const int inf = 99999999; //设99999999代表无穷大
int main() {
	scanf("%d%d%d%d", &n, &m, &c1, &c2);
	//各城市的救援队数量
	for (int i = 0; i < n; i++) {
		scanf("%d", &weight[i]);
	}
	fill(e[0], e[0] + 510 * 510, inf); //初始化填充
	fill(dis, dis + 510, inf);

	int a, b, c;
	for (int i = 0; i < m; i++) {
		scanf("%d%d%d", &a, &b, &c);
		e[a][b] = e[b][a] = c;    //顶点a到顶点b的路径长度为c

	}
	dis[c1] = 0; //开始顶点
	w[c1] = weight[c1];
	num[c1] = 1;
	for (int i = 0; i < n; i++) {
		int u = -1, minn = inf;
		//每次找离出发点最近的顶点
		for (int j = 0; j < n; j++) {
			if (visit[j] == false && dis[j] < minn) {
				u = j;
				minn = dis[j];
			}
		}
		if (u == -1) break; //Dijkstra算法不能有负权路径
		visit[u] = true;
		//将上面找到的该最近顶点进行“松弛”
		for (int v = 0; v < n; v++) {
			if (visit[v] == false && e[u][v] != inf) {
				if (dis[u] + e[u][v] < dis[v]) {
					dis[v] = dis[u] + e[u][v];
					num[v] = num[u];
					w[v] = w[u] + weight[v]; //有最短路径,更新救援队数量
				}
				else if (dis[u] + e[u][v] == dis[v]) {
					num[v] = num[u] + num[v];
					if (w[u] + weight[v] > w[v])
						w[v] = w[u] + weight[v]; //最短路径中救援队数量最多的那个
				}
			}
		}
	}
	printf("%d %d", num[c2], w[c2]);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值