1006. Sign In and Sign Out (25) [查找元素]

1006. Sign In and Sign Out (25) [查找元素]


At the beginning of every day, the first person who signs in the computer room will unlock the door, and
the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are
supposed to find the ones who have unlocked and locked the door on that day.


Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a
positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15
characters.


Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the
door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the
sign out time for each person, and there are no two persons sign in or out at the same moment.


Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40


Sample Output:
SC3021234 CS301133


题⽬⼤意:给出n个⼈的id、sign in时间、sign out时间,求最早进来的⼈和最早出去的⼈的ID~

解:这题我先是用结构体去写的,然后代码很冗余,最后还没运行出来o(╥﹏╥)o,好在思路是跟大佬的差不多 ,so最后代码是参考完大佬的!

#include <iostream>
#include <string>
using namespace std;

int main() {
	int n, minn = 99999999, maxn = -1;
	int h1, m1, s1, h2, m2, s2;
	cin >> n;
	string first_p, final_p;
	for (int i = 0; i < n; i++) {
		string t;
		cin >> t;
		scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
		int isum = h1 * 3600 + m1 * 60 + s1;
		int osum = h2 * 3600 + m2 * 60 + s2;
		if (isum < minn) {
			minn = isum;
			first_p = t;
		}
		if (osum > maxn) {
			maxn = osum;
			final_p = t;
		}
	}

	cout << first_p << " " << final_p;
	return 0;
}

分析:将时间都转换为总秒数,最早和最迟的时间保存在变量minn和maxn中,并同时保存当前最早和 最迟的⼈的ID,最后输出~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值