☆1010. Radix (25) [⼆分法]  

1010. Radix (25) [⼆分法]  


Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is
“yes”, if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of
the other is given.


Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set
{0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35.
The last number “radix” is the radix of N1 if “tag” is 1, or of N2 if “tag” is 2.


Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If
the equation is impossible, print “Impossible”. If the solution is not unique, output the smallest possible
radix.


Sample Input 1:
6 110 1 10
Sample Output 1:
2


Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

题目大意:输入两个数N1、N2,和一个标记tag、一个基数radix,其意义是:tag为1时,radix是N1的基数;tag为2时,radix是N2的基数。方便起见,以下假定tag为1,则目标就是找到一个尽可能小的基数,使N2在此基数下的值等于N1在radix下的值。例如二进制下的110等于十进制下的6。
 

解析: 

1、先求目标数据进制,这个进制在任何条件下面都不能小于2,最大多少呢,不能局限于36,请想象多大都是有可能的,

      因此必须用long long int数据类型;

2、由于数据搜索范围太大,穷举法一个for循环显然会超时,因此选择二分法查找。

     二分法查找搜索上下边界是:目标待求字符串的最小进制一定要比它所包含字符最大值还要大1,

     例如N2="110",最大字符是'1',所以最小应该是1+1=2,注意特例N2="0"。

    上界不能超过另外一个数据的十进制大小,因为N2大于10时,如果它的进制再超过N1的十进制数了的话,

    N2在十进制下的数也就比N1还要大,不符合要求。

3、基数可能会很大,导致N2按此基数算出来之后超过long long的表示范围(也是此题的坑1),需要加一条判断,

     当N2溢出变成负数时,去小的那一半里去找基数。

#include <iostream>
#include <cctype>
#include <cmath>
#include <string>
#include <algorithm>
using namespace std;

//转化为十进制数,n为该数,radix为进制数
long long func(string n, long long radix) {
	long long sum = 0;
	int cnt = 0, temp = 0;
	for (auto it = n.rbegin(); it != n.rend(); it++) {
		temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
		sum += temp * pow(radix, cnt++);
	}
	return sum;
}
//找最小进制基数
long long find_radix(string n, long long num) {
	char it = *max_element(n.begin(), n.end()); //找出n中包含元素的最大那个元素,例n2=110,最大元素是1
	long long low = (isdigit(it) ? it - '0' : it - 'a' + 10) + 1; //最小基数至少是 it+1
	long long high = max(num, low); 
	while (low <= high) {
		long long mid = (low + high) / 2;
		long long t = func(n, mid);
		if (t > num || t < 0) high = mid - 1;
		else if (t == num) return mid;
		else low = mid + 1;
	}
	return -1;
}

int main() {
	string n1, n2;
	long long tag = 0, radix = 0, result_radix;
	cin >> n1 >> n2 >> tag >> radix;
	result_radix = tag == 1 ? find_radix(n2, func(n1, radix)) : find_radix(n1, func(n2, radix));
	if (result_radix != -1) {
		printf("%lld", result_radix);
	}
	else printf("Impossible");
	return 0;
}

最后:代码中用到的一些函数,isdigit()max_element()auto基本用法

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值