pat1013 Battle Over Cities

1013 Battle Over Cities


It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

笔记

最开始的思路是建立一个邻接矩阵,用DFS判断两个城市之间是否存在道路,每占领一个城市则将其城市相关联的其他城市的邻接矩阵进行更新,但是发现会很复杂,难以实现。尤其是到后期的添加几条路径更难得出来。

正确思路
通过连通分量会更加方便,最后需要加的路径就是连通分量个数-1,用DFS,每次占领一个城市就直接将它的visit设置 为true,这样子可以实现这个城市的封闭,既无法从这个城市进行遍历路径,也无法经过。

代码

#include<stdio.h>
#include<stdlib.h>
#define MAXSIZE 1005

int N, M, K;
int road[MAXSIZE][MAXSIZE];
int is_visited[MAXSIZE];

void DFS(int n)
{
	is_visited[n] = 1;
	for (int i = 1; i <= N; i++)
	{
		if (road[n][i] != 0 && is_visited[i] == 0)
			DFS(i);
	}
}

int is_all_visit()
{
	for (int i = 1; i <= N; i++)
	{
		if (is_visited[i] == 0)
			return 0;
	}
	return 1;
}

int main(void)
{
	scanf("%d %d %d", &N, &M, &K);
	for (int i = 0; i < M; i++)
	{
		int b, e;
		scanf("%d %d", &b, &e);
		road[b][e] = 1;
		road[e][b] = 1;
	}
	for (int i = 0; i < K; i++)
	{
		for (int i = 1; i <= N; i++)
			is_visited[i] = 0;
		int m;
		scanf("%d", &m);
		is_visited[m] = 1;
		int num = 0;
		while (!is_all_visit())
		{
			num++;
			for (int i = 1; i <= N; i++)
			{
				if (is_visited[i] == 0)
				{
					DFS(i);
					break;
				}
			}
		}
		printf("%d\n", num - 1);
	}
	system("pause");
}```


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值