数据结构MOOC课后习题 01-复杂度2 Maximum Subsequence Sum

01-复杂度2 Maximum Subsequence Sum

题目要求

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Code:

#include<bits/stdc++.h>
using namespace std;

int a[10005];

int main(){
    int n;
    cin >> n;
    for(int i=1;i<=n;i++) cin>>a[i];
    int MaxSum = -1;
    int ThisSum = 0;
    int left = 1, right = n, templeft = 1, tempright = 1;
    for(int i=1;i<=n;i++){
    	tempright = i;
    	ThisSum += a[i];
    	if(ThisSum > MaxSum){
    		left = templeft;
            right = tempright;
    		MaxSum = ThisSum;
		}
    	if(ThisSum<0){
    		ThisSum = 0;
    		templeft = i+1;
    		tempright=i+1;
		} 
	}
	if(MaxSum<0) cout << 0 << " " << a[1] << " " << a[n] << endl;
    else cout << MaxSum << " " << a[left] << " " <<a [right] << endl;
    
	return 0;
}

解题思路:

这道题是上一道题的难度加大版,需要记录最大子列和首尾的数字,因此需要构建一个数组来存放数字序列以方便计数,注意这里有两个坑,测试时多次未AC。

① 如果序列全为负数时,要输出 ”0 序列首位数字 序列末尾数字“,如果序列中有0存在,其他数字均为负数时,则输出” 0 0 0 “。

② 如果存在多个并列的最大子列和,要输出下标更小的那一组。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值