中国大学MOOC-陈越、何钦铭-数据结构-2021春 01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1, N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , Ni+1​​ , …, Nj​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

# include <stdio.h>
# include <stdlib.h>

int main()
{
    int *a;
    int n,i,first,last,index,count=0;
    scanf("%d",&n);
    a=(int *)malloc(n*sizeof(int));
    for(i=0;i<n;i++)
        scanf("%d",&a[i]);
    int maxsum=0,thissum=0;
    //在线处理,同时每次记录最大子列和maxsum对应的元素信息
     for(i=0;i<n;i++)
    {
           if(a[i]<0)
               count++;//记录负数个数
         thissum+=a[i];
        if(thissum>maxsum)
        {
            maxsum=thissum;
            last=a[i];
            index=i;//更新last的特征
        }
        else if(thissum<0)
            thissum=0;
    }
    thissum=0;
    if(maxsum>0)
         //根据maxsum的值以及记录的last特征进行前扫匹配,需找到first
        //此时数列情况为一定含有正数,需找到first
    for(i=index;i>=0;i--)
    {
          thissum+=a[i];
        if(thissum==maxsum)
        {
            first=a[i];//一定要不断更新first,因为加零maxsum值不会改变,需要找到第一个使之成立的first
        }
         
    }
    else
    {
        if(count==n)//值全为负数
        {
            first=a[0];
            last=a[n-1];
        }
         else
         {
             first=0;
             last=0;
             //数列中不全是负数还有零
         }
    }
     printf("%d %d %d\n",maxsum,first,last);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值