ayit第十四周训练a题

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

 

#include<stdio.h>
#include<string.h>
int book[110][110],n,m,ss,e[110],f[110],w;
int next[8][2]={-2,-1, -2,1, -1,-2,-1,2,1,-2,1,2,2,-1,2,1};
void dfs(int x,int y,int step)
{
    e[step]=x;
    f[step]=y;
    int i,tx,ty;
    if(step==n*m)
    {
        ss=1;
        return;
    }
    for(i=0;i<8;i++)
    {
        tx=x+next[i][0];
        ty=y+next[i][1];
        if(tx>=0&&tx<m&&ty>=0&&ty<n&&book[tx][ty]==0&&ss==0)
        {
            book[tx][ty]=1;
            dfs(tx, ty, step+1);
            book[tx][ty]=0;
        }
    }
}
int main()
{
    int u,b=1,j;
    scanf("%d",&u);
    while(u--)
    {
        ss=0;
        memset( book, 0, sizeof(book));
        memset(e,0, sizeof(e));
        memset(f, 0,sizeof(f));
        scanf("%d%d",&n,&m);
        book[0][0]=1;
        dfs(0,0,1);
        printf("Scenario #%d:\n", b++);
        if(ss==1)
        {
            for(j=1; j<=n*m; j++)
            printf("%c%d",e[j]+'A',f[j]+1);
        }
        else
        printf("impossible");
        printf("\n");
        if(u)
        printf("\n");
    }
    return 0;
}

 

题意  给出一个p行q列的国际棋盘,马可以从任意一个格子开始走,问马能否不重复的走完所有的棋盘。如果可以,输出按字典序排            列最小的路径。输出时,列用大写字母表示,行用阿拉伯数字表示,先输出列,再输出行。

思路    先选择一个固定坐标,题目要求输出路径字典序最小,选择(1,1)也就是作为起点开始搜索;注意移动方向!纵坐标                 从 左到右,纵坐标一样就横坐标从上到下,这样去规定方向数组dx[]和dy[];

题型  深搜

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值