ayit第十五周训练题k题

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
bool prime[10000010];
int main()
{
	int i,j,k=0;
	for(i=2;i*i<=10000000;i++)
    {
		if(!prime[i])
		{

			for(j=i*i;j<=10000000;j+=i)
				prime[j]=1;
		}
    }

	int t,kk=1;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		long long x=0;
		scanf("%d",&n);
		for(i=2;i<=n/2;i++)
		{
			if(!(prime[i]+prime[n-i]))
				x++;

		}
		printf("Case %d: %d\n",kk++,x);
	}
	return 0;
}

题意   给出几组测试数据,每组给出一个n,问n能被分成几对素数的和

思路    先进行素数打表,把数据范围内所有素数存在一个数组之中,然后从数组中的第一个1到最后一个遍历,如果n减去该元素的值还是一个素数的话n++,如果该元素大于等于n/2+1,结束遍历。输出n的值

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值