B - Longest Ordered Subsequence(动态规划)

传送门
B - Longest Ordered Subsequence

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

 7
 1 7 3 5 9 4 8

Sample Output

4

题意:输入一串数字,求出最大的递增序列的长度。

思路:读入每个数字后遍历一遍,使用a[i]>a[j]作为判定条件,后转换成等式dp[i]=max(dp[i],dp[j]+1),最后输出最长递增序列转换成等式sum=max(sum,dp[i])

AC代码

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int a[1050],dp[1050],n;
    cin>>n;
     int sum=0;
    for(int i=1;i<=n;i++)
    cin>>a[i];
    for(int i=1;i<=n;i++)
    {   dp[i]=1;
        for(int j=1;j<i;j++)
        {
         if(a[i]>a[j])
        dp[i]=max(dp[i],dp[j]+1);
          }
         sum=max(sum,dp[i]);
          }
          cout<<sum<<endl;return 0;
       }

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

稚皓君

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值