01背包问题---vj HDU-3466---Proud Merchants

原题链接

Proud Merchants

Problem Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output
For each test case, output one integer, indicating maximum value iSea could get.

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output

5
11

题目大意是:
有n个商品,钱为m
在钱大于等于Qi时可以买下的价格为pi的商品,价值为vi
每件商品可买一次
问可以得到的最大价值为多少

…为什么要以q[i]-p[i]排序
…大神的题解!

01背包问题
说实话,看了大神的题解之后还是不大懂

      for(int i=0;i<=n;i++)
       {
     	 for(int j=m;j>=qi[i];j--)
          {
             // if(j-pi[i]>=qi[i])
               dp[j]=max(dp[j],dp[j-pi[i]]+vi[i]);
         }
       }

遍历到 j 时需要先遍历 j - pi[i] 这样才会算上j-pi[i]时的商品
但是为什么要按照 qi[i] - pi[i]排序…为什么按差值…为什么不是qi[i]排?…

wa代码…:

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

struct node
{
    int pi,qi,vi;
};

int cmp(struct node a,struct node b)
{
    return a.qi<b.qi;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        struct node st[505];
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&st[i].pi,&st[i].qi,&st[i].vi);
        }
        sort(st,st+n,cmp);
        int dp[5005]={0};
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=st[i].qi;j--)
            {
                dp[j]=max(dp[j],dp[j-st[i].pi]+st[i].vi);
            }
        }
//		ceshi
//        for(int i=0;i<=m;i++)
//        printf("%d\n",dp[i]);
        printf("%d\n",dp[m]);
    }

    return 0;
}

…又一篇大神博客

我明白了…

普通的01背包不用考虑物品的先后顺序
但是这个题必须要考虑

它要先买 qi 大但是 pi 小的物品,
dp 的过程是 j=m ; j>=qi ; j-- 所以排序是按照qi-pi 从小到大的顺序

如果它先买 qi 小的 那么它可能就没有钱买 qi 大但是 pi 小的物品了

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

struct node
{
    int pi,qi,vi;
};
int cmp(struct node a,struct node b)
{
    return a.qi-a.pi<b.qi-b.pi;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        struct node st[505];
        for(int i=0;i<n;i++)
         	 scanf("%d%d%d",&st[i].pi,&st[i].qi,&st[i].vi);
        sort(st,st+n,cmp);
        int dp[5005]={0};
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=st[i].qi;j--)
            {
                dp[j]=max(dp[j],dp[j-st[i].pi]+st[i].vi);
            }
        }
        //ceshi
//        for(int i=0;i<=m;i++)
//        printf("%d\n",dp[i]);
        printf("%d\n",dp[m]);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值