大中型企业网项目实战2021-10-07

1/问答题

大中型企业网项目实战
image.png

实验作业:

一、安全管理

1、依据图中拓扑,为全网设备定义主机名、关闭域名解析、并在 Console 和VTY 线路下关闭线路超时并开启输出同步。

依据图中拓扑在GNS3 IOU中搭建企业网

。[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-jO2afjWC-1633579005017)(/Users/aron/Pictures/企业网站2.png)]

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#lin con 0
R1(config-line)#logging
R1(config-line)#logging sync
R1(config-line)#exec-timeout 0 0
R1(config-line)#exit
R1(config)#no  ip do lo

其他同理。

2、为实现安全远程登录,要求在设备 CS1 上创建本地用户名 PingingLab,密码CCIE , 并只允许3个管理员同时远程登录 , 其中管理员地址分别为192.168.10.1~192.168.10.3;要求只运行 SSH 协议进行登录,并且关闭其他虚拟终端线路。

R1(config)#username PingingLab password CCIE
R1(config-line)#line vty 0 2
R1(config-line)#login local
R1(config-line)#exit
R1(config)#access-list 1 permit host 192.168.10.1
R1(config)#access-list 1 permit host 192.168.10.2
R1(config)#access-list 1 permit host 192.168.10.3
R1(config)#line vty 0 2
R1(config-line)#access-class 1 in 
R1(config-line)#exit
R1(config)#line vty 3 4
R1(config-line)#transport input none
R1(config-line)#transport output none
R1(config-line)#end
R1#

R1(config-line)#conf t
R1(config-line)#line vty 0 2
R1(config-line)#transport input ssh
R1(config-line)#transport output ssh
R1(config-line)#

其他设备同理。

3、在设备CS1设置 banner,要求当远程登录时可以看到“THIS IS PingingLabSecure LabCS1”。

CS1(config)#banner login #THIS IS PingingLab*Secure Lab*CS1#
CS1(config)#exit

4、在CS2关闭 HTTP 服务,开启HTTPS服务并调用本地认证。

CS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
CS2(config)#no ip http server 
CS2(config)#ip http ?
  access-class                   Restrict http server access by access-class
  active-session-modules         Set up active http server session modules
  authentication                 Set http server authentication method
  client                         Set http client parameters
  digest                         Set http digest parameters
  help-path                      HTML help root URL
  max-connections                Set maximum number of concurrent http server
                                 connections
  path                           Set base path for HTML
  port                           Set http port
  secure-active-session-modules  Set up active http secure server session
                                 modules
  secure-ciphersuite             Set http secure server ciphersuite
  secure-client-auth             Set http secure server with client
                                 authentication
  secure-port                    Set http secure server port number for
                                 listening
  secure-server                  Enable HTTP secure server
  secure-trustpoint              Set http secure server certificate trustpoint
  server                         Enable http server
  session-module-list            Set up a http(s) server session module list
  timeout-policy                 Set http server time-out policy parameters
          
CS2(config)#ip http secure-server 
% Generating 1024 bit RSA keys, keys will be non-exportable...
[OK] (elapsed time was 0 seconds)
Failed to generate persistent self-signed certificate.
    Secure server will use temporary self-signed certificate.

CS2(config)#
*Oct  6 09:10:41.225: %SSH-5-ENABLED: SSH 1.99 has been enabled
CS2(config)#


5、在R1的 E0/0上关闭 CDP 服务。

R1(config)#no cdp run
R1(config)#

5、汇聚和接入交换机的管理 vlan 为 vlan1,所在网段为 192.168.1.0/24,其中DS1 的管理 IP 为 192.168.1.1/24,DS2 为 192.168.1.2/24,DS3 为192.168.1.3/24,DS4 为 192.168.1.4/24 。要求二层交换机可以远程管理。

DS1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DS1(config)#int vlan 1
DS1(config-if)#no sh
DS1(config-if)#ip add 192.168.1.1 255.255.255.0
DS1(config-if)#end

DS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DS2(config)#int vlan 1
DS2(config-if)#ip add 192.168.1.2 255.255.255.0
DS2(config-if)#no sh


AS1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
AS1(config)#   no ip routing
AS1(config)#ip default-gateway 192.168.1.1              
AS1(config)#end
AS1#show ip route
Default gateway is 192.168.1.1

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty
AS1#


AS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
AS2(config)#no ip routing
AS2(config)#ip default-gateway 192.168.1.2 
AS2(config)#end

AS2#show ip route
Default gateway is 192.168.1.2

Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty
AS2#

二、交换技术

1、Trunk 技术

①DS1、DS2、AS1 交换机之间强制启用 Trunk 并关闭 DTP 协商,并采用802.1Q 进行封装。

②AS2 和其他交换机之间采用 DTP 协议协商 Trunk,AS2 端为 Auto 模式,其他交换机为 Desirable 模式。

③所有交换机要求 Trunk 上只允许 VLAN1、10、20、30、40 通过。

DS1(config)#int range e0/1 , e0/2 , e0/3 , e1/0
DS1(config-if-range)# switchport trunk encapsulation dot1q
DS1(config-if-range)# switchport trunk allowed vlan 1,10,20,30,40
DS1(config-if-range)# switchport mode trunk
DS1(config-if-range)#


DS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DS2(config)#int range e0/2 , e0/1 , e1/0 , e0/3 
DS2(config-if-range)# switchport trunk encapsulation dot1q
DS2(config-if-range)# switchport trunk allowed vlan 1,10,20,30,40
DS2(config-if-range)# switchport mode trunk
DS2(config-if-range)#

AS1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
AS1(config)#int range e0/0 - 1
AS1(config-if-range)# switchport trunk encapsulation dot1q
AS1(config-if-range)# switchport trunk allowed vlan 1,10,20,30,40
AS1(config-if-range)# switchport mode trunk
AS1(config-if-range)#

AS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
AS2(config)#int range e0/0 - 1
AS2(config-if-range)# switchport trunk encapsulation dot1q
AS2(config-if-range)# switchport trunk allowed vlan 1,10,20,30,40
AS2(config-if-range)# switchport mode trunk
AS2(config-if-range)#

DS1#show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/1       on               802.1q         trunking      1
Et0/2       on               802.1q         trunking      1
Et0/3       on               802.1q         trunking      1
Et1/0       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/1       1,10,20,30,40
Et0/2       1,10,20,30,40
Et0/3       1,10,20,30,40
Et1/0       1,10,20,30,40

Port        Vlans allowed and active in management domain
Et0/1       1
Et0/2       1
Et0/3       1
Et1/0       1

Port        Vlans in spanning tree forwarding state and not pruned
Et0/1       1
Et0/2       1
Et0/3       1
Et1/0       1

AS2#show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Et0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Et0/0       1,10,20,30,40
Et0/1       1,10,20,30,40

Port        Vlans allowed and active in management domain
Et0/0       1
Et0/1       1

Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       none
Et0/1       1
AS2#

2、VTP&VLAN 技术

①总部 DS1 和 DS2 均为 Server,其他交换机为 Client。

②总部 VTP 管理域为 PingingLab,密码为 cisco。

④在 DS1 上创建 VLAN10/20/30/40,并要求全局同步。

DS1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DS1(config)#vtp mode server 
DS1(config)#vtp domain PL
DS1(config)#vtp password cisco
DS1(config)#do wr
Building configuration...
Compressed configuration from 2200 bytes to 1285 bytes[OK]
DS1(config)#
DS1(config)#vlan 10
DS1(config-vlan)#vlan 20
DS1(config-vlan)#vlan 30
DS1(config-vlan)#vlan 40
DS1(config-vlan)#end


DS2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DS2(config)#vtp mode server 
DS2(config)#vtp domain PL
DS2(config)#vtp password cisco
DS2(config)#

AS1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
AS1(config)#vtp mode client 
AS1(config
  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值