2021-03-08

HDU 1163

题目链接

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy’s easy problem is that : give you the n,want you to find the n^n’s digital Roots.

Input

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy’s easy problem is that : give you the n,want you to find the n^n’s digital Roots.

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output

Output n^n’s digital root on a separate line of the output.

Sample Input

2
4
0

Sample Output

4
4

Output

Output n^n’s digital root on a separate line of the output.

Sample Input

2
4
0

Sample Output

4
4

Code

#include <iostream>
#include <algorithm>
using namespace std;
const int MOD = 9;

long long QuickPower(long long base, long long power);
int main()
{
    long long N;
    while (scanf("%lld", &N) != EOF && N)
    {
        long long result = QuickPower(N, N);
        if (result == 0)
            result = 9;
        printf("%lld\n", result);
    }

    return 0;
}
long long QuickPower(long long base, long long power)
{
    long long result = 1;
    while (power)
    {
        if (power & 1)
        {
            result *= base;
            result %= MOD;
            if (result == 0)
                result = 9;
        }
        power >>= 1;
        base = (base * base) % MOD;
    }

    return (result % MOD);
}

首先这个题是个找规律的题目啦,直接去模拟这个过程肯定会超时的;

规律:N的数字根是N%9的结果,但是,当N%9==0时,N的数字根是9,自己可以试试;

其次就是题目中是输入n,但是要求的是N的N次方的数字根,那么根据快速幂和的思想,我们发现,我们只有在快速幂过程中把每一步都对9求模,就可以了,但是也要注意在快速幂里面的result如果等于0了,要把result改成9,具体为什么,上面已经说过了;快速幂不会的自己去学啦.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值