hud 1013 求一个数的数字根(合九法||模拟)

题目链接: 点击打开链接
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output For each integer in the input, output its digital root on a separate line of the output.


Sample Input
24
39
0

Sample Output
6
3


题意:给你一个数,这个数a可能非常大,把数a的各个位上的数字加起来得到b,若b小于10则输出b,否则继续将数b的各个位加起来直到加起来的数小于10再将其输出。

思想方法:合九法,将一个数的各个位上的数字加起来得到另一个数字,再将另一个数字的各个位上的数字加起来,直到加起来的数字的位数为一位,那么最终的这个数就是原数的数字根。数字根等于将一个数的各个位上的数字加起来取余9.

模拟代码

#include<stdio.h>
#include<string.h>
int f(int x)
{
    int s=0;
    while(x)
    {
        s+=x%10;
        x/=10;
    }
    return s;
}
int main()
{
    char a[10005];
    while(~scanf("%s",a))
    {
        if(a[0]=='0')
            break;
        int ans=0,l=strlen(a);
        for(int i=0;i<l;i++)
            ans+=a[i]-'0';
        if(ans<=9)
            printf("%d\n",ans);
        else
        {
            int b=ans;
            while(b>9)
                b=f(b);
            printf("%d\n",b);
        }
    }
}
利用合九法解:

#include<stdio.h>
#include<string.h>
int main()
{
    char  s[1000];
    int len,sum,i;
    while(scanf("%s",&s)!=EOF)
    {
        len=strlen(s);
        if(s[0]=='0') return 0;
        for(sum=0,i=0;i<len;i++)
            sum+=s[i]-'0';
        printf("%d\n",sum%9?sum%9:9);
    }
}

思考:解题思想类似进制转换思想,但取的是进制转换的后的最后一位数字就是答案。唯一一点不同的是,当整除是“余数”不应该写0,而应该是转换的进制数,例如:18%9=0;此时答案应该是9而不是0.

扩展:“弃九法”也叫做弃九验算法,利用这种方法可以验算加、减计算的结果是否错误。把一个数的各位数字相加,直到和是一个一位数(和是9,要减去9得0),这个数就叫做原来数的弃九数。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值