PAT甲级1127 ZigZagging on a Tree (30分)

PAT甲级1127 ZigZagging on a Tree (30分)

题面

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

总结

个人感觉这题一定要动手写写草稿,核心代码:

root->lchild = build(midL, midL+mark-1, proL, proL+mark-1);
root->rchild = build(midL+mark+1, midR, proL+mark, proR-1);

然后这个mark指的是中序遍历根的第k项减去midL:
mark = k - midL;

AC代码

#include <bits/stdc++.h>
using namespace std;

int n;
int pro[50],mid[50];
struct node{
	int data;
	int layer;
	struct node *lchild, *rchild;
};
vector<int> v;

struct node* build(int midL, int midR, int proL, int proR){
	if(midL > midR || proL > proR){
		return NULL;
	}
	struct node *root;
	root = new node;
	root->data = pro[proR];
	root->lchild = root->rchild = NULL;
	int k,mark;
	for(k=midL; k<=midR;k++){
		if(mid[k] == pro[proR]) break;
	}
	mark = k - midL;
	root->lchild = build(midL, midL+mark-1, proL, proL+mark-1);
	root->rchild = build(midL+mark+1, midR, proL+mark, proR-1);
	return root;
}

void bfs(struct node* &root){
	queue<node*> q;
	root->layer = 1;
	q.push(root);
	while(!q.empty()){
		struct node *tmp = new node;
		tmp = q.front();
		q.pop();
		if(tmp->lchild){
			tmp->lchild->layer = tmp->layer+1;
			q.push(tmp->lchild);
		}
		if(tmp->rchild){
			tmp->rchild->layer = tmp->layer+1;
			q.push(tmp->rchild);
		}
	}
}

void print(struct node *root){
	queue<node*> q;
	q.push(root);
	while(!q.empty()){
		struct node* tmp = new node;
		tmp = q.front();
		q.pop();
		//cout<<tmp->data<<"  layer = "<<tmp->layer<<endl;
		if(tmp->data == root->data) cout<<tmp->data;
		else if(tmp->layer % 2) 
			v.push_back(tmp->data);
		else{
			if(v.size()!=0){
				for(int i=v.size()-1; i>=0 ;i--){
					cout<<" "<<v[i];
				}
				v.clear();
			}
			cout<<" "<<tmp->data; 
		}
		if(tmp->lchild) q.push(tmp->lchild);
		if(tmp->rchild) q.push(tmp->rchild);
	}
	if(v.size()!=0){
		for(int i=v.size()-1;i>=0;i--){
			cout<<" "<<v[i];
		}
	}
}

int main(){
	cin>>n;
	for(int i=1;i<=n;i++) cin>>mid[i];
	for(int i=1;i<=n;i++) cin>>pro[i];
	struct node *root = NULL;
	root = build(1,n,1,n);
	bfs(root);
	print(root);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值