Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
结尾无空行
Sample Output:
1 11 5 8 17 12 20 15
思路:先建数,DFS记录下每个结点的深度,再根据深度的奇偶来决定是否逆序
#include <bits/stdc++.h>
using namespace std;
const int maxv=35;
struct node
{
int data;
node *left,*right;
node(int x):data(x),left(NULL),right(NULL){}
};
int n,maxheight=-1;
vector<int> height[maxv];
vector<int> in,post;
node *create(int inl,int inr,int postl,int postr)
{
if(inl>inr||postl>postr) return NULL;
node *root=new node(post[postr]);
for(int i=inl;i<=inr;i++)
{
if(in[i]==post[postr])
{
root->left=create(inl,i-1,postl,postl+i-inl-1);
root->right=create(i+1,inr,postl+i-inl,postr-1);
break;
}
}
return root;
}
void DFS(node *root,int depth)
{
if(!root)
{
maxheight=max(maxheight,depth);
return;
}
height[depth].push_back(root->data);
DFS(root->left,depth+1);
DFS(root->right,depth+1);
}
int main()
{
int n;
scanf("%d",&n);
in.resize(n);post.resize(n);
for(int i=0;i<n;i++) scanf("%d",&in[i]);
for(int i=0;i<n;i++) scanf("%d",&post[i]);
DFS(create(0,n-1,0,n-1),0);
printf("%d",height[0][0]);
for(int i=1;i<maxheight;i++)
{
if(i%2==0) reverse(height[i].begin(),height[i].end());
for(int j=0;j<height[i].size();j++) printf(" %d",height[i][j]);
}
return 0;
}