ACWING 829. 模拟队列 (队列)

实现一个队列,队列初始为空,支持四种操作:

push x – 向队尾插入一个数 x;
pop – 从队头弹出一个数;
empty – 判断队列是否为空;
query – 查询队头元素。
现在要对队列进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。

输入格式
第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push x,pop,empty,query 中的一种。

输出格式
对于每个 empty 和 query 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YES 或 NO,query 操作的查询结果为一个整数,表示队头元素的值。

数据范围
1≤M≤100000,
1≤x≤109,
所有操作保证合法。

输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4

https://www.acwing.com/problem/content/831/

#include<bits/stdc++.h>
using namespace std;

const int N=100010;

int qu[N];
int head=1;
int tail=0;

void push(int x) {
    qu[++tail]=x;

}

void pop() {
    if(tail>=head) head++;
    else cout<<"FBI WARNING\n";

}

bool empty() {
    if(tail>=head) return false;
    else return true;

}

int query() {
    if(tail>=head) return qu[head];
    else cout<<"FBI WARNING\n";
    return -1;
}


int main() {

    int n;
    cin>>n;
    string str;
    int x;
    while(n--) {
        cin>>str;

        if(str=="push") {
            cin>>x;
            push(x);

        } else if(str=="pop") {
            pop();

        } else if(str=="empty") {
            if(empty()) cout<<"YES\n";
            else cout<<"NO\n";

        } else {
            cout<<query()<<"\n";

        }

    }

    return 0;
}

  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值