ACWING 847. 图中点的层次 (树与图的广度优先遍历)

给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环。

所有边的长度都是 1,点的编号为 1∼n。

请你求出 1 号点到 n 号点的最短距离,如果从 1 号点无法走到 n 号点,输出 −1。

输入格式
第一行包含两个整数 n 和 m。

接下来 m 行,每行包含两个整数 a 和 b,表示存在一条从 a 走到 b 的长度为 1 的边。

输出格式
输出一个整数,表示 1 号点到 n 号点的最短距离。

数据范围
1≤n,m≤105
输入样例:
4 5
1 2
2 3
3 4
1 3
1 4
输出样例:
1

https://www.acwing.com/problem/content/849/

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

const int N=100010;
int n,m;
int h[N], e[N], ne[N], idx=1;

int d[N], q[N];
bool book[N];

void add(int a, int b) {
    e[idx]=b;
    ne[idx]=h[a];
    h[a]=idx++;
    return ;
}

int bfs() {
    int hh=0, tt=1;
    q[hh]=1;
    d[1]=0;
    book[hh]=true;

    while(hh<tt) {
        int t=q[hh];
        for(int i=h[t];i;i=ne[i]) {
            int j=e[i];
            if(!book[j]) {
                q[tt]=j;
                d[j]=d[t]+1;
                book[j]=true;
                tt++;
            }
        }
        hh++;
    }
    return d[n];
}

int main() {

    ios::sync_with_stdio(false);
    cin.tie(0), cout.tie(0);

    cin>>n>>m;
    int a,b;
    while(m--) {
        cin>>a>>b;
        add(a,b);
    }
    int ans=bfs();
    if(ans) cout<<ans<<endl;
    else cout<<-1<<endl;

    return 0;
}

//n 个无向边,q 到p 的最短距离
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

const int N=100010;
int e[N], ne[N], h[N], idx=1;

int que[N], hh, tt, s[N];
bool book[N];

void add(int a, int b) {
    e[idx]=b;
    ne[idx]=h[a];
    h[a]=idx++;
}

void bfs(int p, int q) {
    bool flag=false;
    tt=1;
    que[hh]=p;
    s[hh]=0;
    while(hh<tt) {
        int k=que[hh];

        for(int i=h[k]; i; i=ne[i]) {
            if(!book[e[i]]) {
                que[tt]=e[i];
                book[e[i]]=true;
                s[tt]=s[hh]+1;
                tt++;

                if(e[i]==q) {
                    flag=true;
                    break;
                }

            }

        }
        hh++;

        if(flag) {
            cout<<s[tt-1]<<endl;
            break;
        }
    }
    return ;
}

int main() {

    ios::sync_with_stdio(false);
    cin.tie(0), cout.tie(0);

    int n;
    cin>>n;
    int a,b;
    while(n--) {
        cin>>a>>b;
        add(a,b);
        add(b,a);
    }

    int p,q;
    cin>>p>>q;

    bfs(p,q);


    return 0;
}

/*

8
1 2
1 4
1 7
2 8
2 5
4 3
4 6
3 9

*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值