题目描述
有n个整数,使前面各数顺序向后移m个位置,最后m个数变成前面m个数,写一函数:实现以上功能,在主函数中输入n个数和输出调整后的n个数。
输入
输入数据的个数n n个整数 移动的位置m
输出
移动后的n个数
样例输入
10
1 2 3 4 5 6 7 8 9 10
2
样例输出
9 10 1 2 3 4 5 6 7 8
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
int main()
{
int n,f,m,x;
scanf("%d",&n);///输入要输入数字的个数
int a[n];
for(f=0;f<n;f++)
{
scanf("%d",&a[f]);///存放数字
}
scanf("%d",&m);///向右移动位数
for(x=n-m;x<n;x++)
{
printf("%d ",a[x]);///先输出将被替换的后面元素,前置后元素
}
for(x=0;x<n-m;x++)
{
printf("%d ",a[x]);///不可描述。。。。。
}
printf("\n");
}