【中国大学MOOC-陈越、何钦铭-数据结构-起步能力自测题】自测4 Have Fun with Numbers

Question:
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899
结尾无空行

Sample Output:

Yes
2469135798
结尾无空行

代码

#define _CRT_SECURE_NO_WARNINGS 1 
#include<stdio.h>
#include <string.h>
int judge(int arr1[],int arr2[],int x)
{
	for (int i = 0; i < x; i++)
	{
		if (arr1[i] != 0 && arr2[0] != 0)
		{
			return 0;
		}
	}
	return 1;
}
int main()
{
	char temp1[22];//方便存入

	scanf("%s", temp1);
	int sz = strlen(temp1);//计算位数
	int a[50] = { 0 };
	int b[51] = { 0 };
	int dit[10] = { 0,0,0,0,0,0,0,0,0,0 };

	for (int i = 0; i < sz; i++)
	{
		a[i] = temp1[i] - '0';	//temp中的数字存入整型数组
		dit[a[i]]++;//记录0-9数字分别的个数
	}
	int carry_bit = 0;
	for (int i = sz - 1; i >= 0; i--)
	{
		b[i+1] =carry_bit;
		int amass= a[i] * 2 ;
		if (amass >=10)
		{
			b[i+1] = amass % 10+b[i+1];
			carry_bit = (amass -b[i+1]+ carry_bit)/10;
			if (b[i+1] >= 10)
			{
				carry_bit++;
				b[i+1] = b[i+1] - 10;
			}

		}
		else
		{
			b[i+1] = amass+b[i+1];
			carry_bit = 0;
		}

	}
	b[0] = carry_bit;
	for (int i = 0; i < sz; i++)
	{
		dit[b[i+1]]--;
	}

	if (judge(dit,b,sz)== 0)
	{
		printf("No\n");
		for (int i = 0; i < sz + 1; i++)
		{
			printf("%d", b[i]);
		}
	}
	else
	{
		printf("Yes\n");
		for (int i = 1; i < sz + 1; i++)
		{
			printf("%d", b[i]);
		}
		
	}

	return 0;
}
  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

XiYang-DING

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值