ZOJ1149 Dividing

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line 1 0 1 2 0 0’‘. The maximum total number of marbles will be 20000.

The last line of the input file will be 0 0 0 0 0 0’'; do not process this line.

Output

For each colletcion, output Collection #k:‘’, where k is the number of the test case, and then either Can be divided.‘’ or ``Can’t be divided.‘’.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

分析:

首先要做的就是数据处理,不需要对每种价值的大理石都全部平分。在能保证结果正确的情况下,最少分配的大理石数目是6(但并不能完全保证,依然有数据不正确.至于为什么取6,我也不太懂,希望能有大佬帮帮我),然后就可以确定大理石最大价值最多为126,只要一个人可以取走一半,那一定可以平分。

代码:

#include <bits/stdc++.h>
#define eps 1e-15
using namespace std;
int a[7],dp[65],sum,mid;//a数组表示每种价值的大理石数目,dp表示一个人分得i价值的大理石有没有可能
void solve(){
    for(int i = 0; i <= 64;i++)
        dp[i] = 0;
    dp[0] = 1;
    int t;
    for(int i = 1; i <= 6; i++)
        for(int v = mid; v >= 0; v--){
        //需要从mid开始,防止循环中产生的数据再次对此次循环造成影响
            if(dp[v])
            for(int j = 1; j <= a[i]; j++){
                t = v+j*i;
                if(t > mid)break;
                else dp[t] = 1;
                if(t == mid){cout<<"Can be divided."<<endl<<endl;return;}
            }
        }
    cout<<"Can't be divided."<<endl<<endl;
}

int main()
{
    int f = 1;
    while(1){
        sum = 0;
        for(int i=1;i<=6;i++){
            cin>>a[i];
            //数据处理
            if(a[i] != 0 && a[i] % 6 ==0)a[i] = 6;
            else a[i] = a[i] % 6;
            sum += i*a[i];
        }
        if(sum == 0)break;
        mid = sum/2;
        cout<<"Collection #"<<f++<<':'<<endl;
        if(sum%2){cout<<"Can't be divided."<<endl<<endl;}
        else solve();
    }
    return 0;
}

2022/4/4更改
又看了另一个版本,使用二进制优化减少数据量,转化成0-1背包。
二进制优化,就是将同一类的多个物品转化成多个不同的物品,大大减少数量。转化方法就是让原来商品的重量与价值都乘一个系数k,k的取值为,1,2,4,…,2^(k-1),n-2 ^k+1且n-2 ^k+1>0。
可行性分析,转化后的值可以表示未转化时的任意值。例如有10个价值为1的大理石,可以转化成1,2,4,3。1-7的值都可以由1,2,4组合表示,8-10的值减去3后又属于1-7的值。
代码:

#include <bits/stdc++.h>
#define eps 1e-15
using namespace std;
int a[7],dp[210005],sum;
void solve(){
    //二进制优化
    int n=1,b[100],k,x;
    for(int i=1; i<=6; i++){
        k=1;
        x=0;
        while(k < a[i]){
            b[n++] = k*i;
            x += k;
            k *= 2;
        }
        if(a[i] > x)b[n++] = (a[i] - x)*i;
    }
    memset(dp, 0, sizeof(dp));
    //0-1背包
    dp[0] = 1;
    for(int i=1; i<=n-1; i++){
        for(int j=sum/2; j>=0; j--){
            if(dp[j])dp[j+b[i]] = 1;
        }
    }
    if(dp[sum/2])cout<<"Can be divided."<<endl<<endl;
    else  cout<<"Can't be divided."<<endl<<endl;
}

int main()
{
    int f=1;
	while(1){
        sum = 0;
        for(int i=1; i<=6; i++){
            cin>>a[i];
            sum+=i*a[i];
        }
        if(sum == 0)break;
        cout<<"Collection #"<<f++<<':'<<endl;
        if(sum%2){cout<<"Can't be divided."<<endl<<endl;}
        else solve();
	}

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值