PAT A1080

1080 Graduate Admission (30 分)
It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G
E

, and the interview grade G
I

. The final grade of an applicant is (G
E

+G
I

)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G
E

. If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:
Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G
E

and G
I

, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
结尾无空行
Sample Output:
0 10
3
5 6 7
2 8

1 4
结尾无空行

#include<cstdio>
#include<algorithm>
using namespace std;
struct stu{
	int id;
	int Ge;
	int Gi;
	int final;
	int t[6];
	int rank;
} s[40010]; 
bool cmp(struct stu a,struct stu b)
{
	if(a.final!=b.final) return a.final>b.final;
	if(a.Ge!=b.Ge) return a.Ge>b.Ge;
	return a.id<b.id;
}
bool cmp1(int x,int y)
{
	return s[x].id<s[y].id;
}
int accept[110][40010]={0} ; 
int main()
{
	int n,m,k;
	int school[110],count[110]={0};
	scanf("%d%d%d",&n,&m,&k);
	for(int i=0;i<m;i++)
	{
		scanf("%d",&school[i]);
	}
	for(int i=0;i<n;i++)
	{
		s[i].id=i;
		scanf("%d%d",&s[i].Ge,&s[i].Gi);
		s[i].final=s[i].Ge+s[i].Gi;
		for(int j=0;j<k;j++)
		scanf("%d",&s[i].t[j]);
	}
	sort(s,s+n,cmp);
	
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<k;j++)
		{
			if(count[s[i].t[j]]<school[s[i].t[j]])
			{
				accept[s[i].t[j]][count[s[i].t[j]]]=i;
				count[s[i].t[j]]++;
				break;
			}
			else if(school[s[i].t[j]]!=0&&count[s[i].t[j]]>=school[s[i].t[j]]&&s[i].final==s[accept[s[i].t[j]][count[s[i].t[j]]-1]].final&&s[i].Ge==s[accept[s[i].t[j]][count[s[i].t[j]]-1]].Ge)
			{
			//	accept[s[i].t[j]][count[s[i].t[j]]]=s[i].id;
				accept[s[i].t[j]][count[s[i].t[j]]]=i;
				
				count[s[i].t[j]]++;
				break;
			}
			
		}
	}
	//printf("%d",count[0]);
	for(int i=0;i<m;i++)
	{
		sort(accept[i],accept[i]+count[i],cmp1);
	//	if(!(accept[i][0]==0&&accept[i][1]==0))
		for(int j=0;j<count[i];j++)
		{
			printf("%d",s[accept[i][j]].id);
			if(j!=count[i]-1)
			printf(" ");
		}
		printf("\n");
	}
	
	return 0;
}
/*
5 5 3
0 0 0 5 5
100 100 0 1 2
100 99 1 2 0
99 100 2 1 0
99 99 1 0 2
98 98 2 0 1
*/

这题有两个问题
第一个是定义太大的数组不能在main里 会段错误
全局变量在静态存储区分配内存,局部变量是在栈上分配内存空间的。(c语言程序在运行时会动态创建一个堆栈段,里面存放着调用栈,保存着函数的调用关系和局部变量。)如果数组太大,可能会造成栈溢出。

第二个

else if(school[s[i].t[j]]!=0&&count[s[i].t[j]]>=school[s[i].t[j]]&&s[i].final==s[accept[s[i].t[j]][count[s[i].t[j]]-1]].final&&s[i].Ge==s[accept[s[i].t[j]][count[s[i].t[j]]-1]].Ge)
			{
			//	accept[s[i].t[j]][count[s[i].t[j]]]=s[i].id;
				accept[s[i].t[j]][count[s[i].t[j]]]=i;
				
				count[s[i].t[j]]++;
				break;
			}

注释部分为修改前后,这里我错是因为保存的是id,使用的accept[s[i].t[j]][count[s[i].t[j]]-1]是排序后的s[]序号,用这种太多的数组变量嵌套容易把自己绕晕,多用几个中间变量好了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值